Have register browser over and over again


Hi, thanks for the response.

The browser is the Google Chrome browser and doesn’t have any setttings configured to clear anything out at the end of sessions - I actually don’t close the browser unless I reboot the Chromebook, the browser is open on the chromebook 24/7.

This didn’t use to happen, which is the odd part. I could return to the Dashboard w/out having to re-register, then one day (can’t rmemeber when, unfortunately) it started making me re-register. Weird.


New laptop arrived today that is replacing my aging Chromebook, so the whole issue becomes mostly moot. :slight_smile:

That’s one way to solve a problem, throw hardware at it. :smiley:



When you say every time, do you get logged out or when you close the dashboard tab?
Because every time I close the dashboard tab I get logged out…
I thought that was the standart…


It wasn’t that I was getting logged out, I had to re-register the browser again first by getting the code from the WebCore app in the SmartThings app, and then log into WebCore.

I’m used to having to log in again, but having to re-register my browser repeatedly was not normal.


well then I have the same problem because I have to register my browser every time…


Once a browser is registered it should stay registered AFAIK. I don’t remember having to continually re-register my browser in the past.



I’ve been using Safari for it…
I’m going to try Chrome…


This can also happen when you use a Firefox “Private” or Chrome “Incognito” window…


Yeah, but I’m using a normal browser tab in Chrome, not incognito. :slight_smile:


It sounds like there was an issue with your old Chromebook and/or the Chrome browser there. It should remember indefinitely unless cookies are cleared, or incognito (where there are no cookies set).


So let me understand this WC,
You guys are registering your webcore and if you close that dashboard page and re-open it, you don’t have to register again.(I have to even if they are 2 minutes apart)


Correct. I open my ST app, then go to webCoRE settings, then register browser.
I only have to do this once per browser or device.

The only time I have to repeat those steps again is on a new phone, tablet, computer, or browser.
(or if I clear my browsing history)


:joy::joy::rofl::rofl: I can’t believe I’ve been doing this everyday almost 5-6 times for a year now, without questioning it…And I never clear my browsing history…:rofl::rofl::rofl:


I would be very tempted to try another device (or browser) to see if it sticks for you.

Doing that every day would drive me batty!?!


Good idea… I have PC as well, I will try on that right now…


Nope same thing…


Hmmm… Can you try a different browser on the PC?
It seems the cookie is not being saved for that browser


I have tried both Mozilla and Chrome and I get the same behavior - I will need to re-register the browser every time I login.


I don’t have an Android handy, but I think under:
Android > SmartThings app > webCoRE > Settings > Something or other
there is an option that adjusts this.


I’ve started to get this on Chrome for Android, out of nowhere on a daily basis. And each time I get a pop-up “There was a problem loading your devices…”

RESOLVED: Problem loading the dashboard data. The data shown below may be outdated