Piston not subscribing to anything


I am trying to control my furnace depending on the mode of my location (Away, Home, Night, etc). This was working great with Core but now I am trying to put this in WebCore and I am not having much luck.

Here is my webcore:

The problem I have is that it says:

This piston does not subscribe to any events. Unless executed by other means, it will never run on its own.

Here are the quick facts:
Quick facts
Piston state: false
Last executed: 9/19/2017, 7:26:31 AM
Next scheduled: never
Subscriptions: no events, 1 control
Devices used: 1
Memory used: 3% (3361 bytes)
External URL: (click to open/execute)

As you can see I even selected “Always Subscribe” on my if statements and it did not change.

Conditions and Triggers: The difference?

I’m not certain on this but try moving your IFs out of the group. The group is not needed in this scenario. Just don’t select group when setting the IFs.


no change.


Can {$locationmode} be used for creating events? It worked in CORE…


I was trying to find specifics on that but I believe that’s the issue - you can’t subscribe to that variable.


ok, do you have any suggestions on how I should do this then?


Never mind, I just found a Virtual Device called location mode and using that fixes the issue.


Beat me to it.