Setting Dimmer Level without turning on


Can someone please look at this piston and let me know what else I need to do to accomplish the following:

-If both the LIFX lights are on, then piston may proceed to slowly turn it to off over time
-If both LIFX lights are off, then do not proceed with the above

I want this just in case I manually turn these lights off during the period of it slowly fading them to off to prevent them from coming back on. As discussed above, it appears that an ‘on’ command is given each time…

I tested the below set-up during the fade down time period with the lights off and it still turned them back on…



are these bulbs both at the same level when the fade starts?


Yes…same level…and because I don’t normally use the LIFX app, everything is in sych with ST (ST is turning them on and off so the synch is correct…)

The way I programmed the piston, I believe, WebCoRE should be seeing that they are off and not execute the piston. I watched their status on ST prior to starting the piston and they definitely showing off.


ok. why is there an extra if at line 27 of the piston image above? did you mean to have some other logic there? please post a green snapshot with the code. dont want to start from scratch. :slight_smile:


No idea, but I deleted it and you fixed it :slight_smile: Thanks…works like it intended it now…appreciate it…

Update :frowning:

It didn’t work tonight…As it was progressing in the fade, I thought I would try by turning off both LIFX lights. I made sure they registered as OFF on ST for both lights and they did…WebCoRE still initiated the fade command…Turned both lights off again and on the next downtown (fade level) the lights went back on, again…I’m wondering if it is ignoring that they are off because it has already set up the stage for each progressive fade? Maybe the piston needs to be arranged in a different way?


Well, I haven’t solved my problem yet, but I do have the same dimmers as you. I don’t know if this helps or not, but you can set the minimum and maximum settings at the physical dimmer…There’s a variety of settings and these are a couple of them. You could set the dimmer to a fairly low setting for maximum and regardless of how high you try to make it, it won’t go higher than what you set the limit for. Like I said, I don’t know if that helps, but it’s possible (consult the manual for enter into programming…)


Thanks for the suggestion @smartie. Unfortunately I love powerful lighting which is why I use dimmers as I put the most light I can in a room and then dim down if needed. Setting max dim level would defeat this so I cannot do that but I appreciate your suggestion.


missed your post edit, but have you fixed your problem?


Good catch. I actually let this one slide. I thought about it and decided it really made no difference if it fades to turn off. The resolution? Just an off command :). It works fine that way.


I know this is an old thread, but how about this as a potential mitigation. Just conceptual, but here it is:

Whenever you turn off either a dimmer or a smart bulb, have an automation that intercepts the action.
That automation turns the bulb back on, and then sets a variable - whose default value is false - to true. Needed in order to run the automation only once.

The automation sets the luminance level of the bulb, and turns it off.

Now… of course the automation would intercept the light turning off, right? And you’d get an endless loop.

You configure the piston such that “if light is turned off while variable is true, do not run the action”.
Only run the action if light is turned off while variable is false.

As the final step, two seconds after the action turns the light off it resets the variable to false.

You’d have to live with every light/dimmer for which this is configured flickering briefly after being turned off… but that’s probably the least objectionable of the various consequences.


If I’m understanding the situation correctly, here’s another idea.

Set light to 10%
When you turn on light at normal time, it comes on at 10%, and if time is before 10:00, then set level to 100%. When you turn light off, it turns bulb down to 10% then off.

If time is after 10:00, then don’t increase level. Turning light off keeps it at 10%. The only possible drawback is waiting for the light to turn to maximum during normal hours, depending on the speed of the setting change.


I have many GE Dimmers from Jasco for my office. My goal is to have a scene or use Alexa to set the lights to a lower level when we have a presentation. I want to have the lights fade and not jump to the lower level. I am really new to Smartthings. I was trying to use but it does not work. GE tech guy recommend to use Smartthings. Any help would be appreciated. I don’t understand why this is so difficult. When I watch those home shows and people have home theaters, how do they change their lights to a lower level? Again thanks for the advise.


Create a Simulated Switch in the IDE. (let’s call it “Presentation”)
Link it to Alexa and webCoRE

The piston in webCoRE can be simply:

IF Presentation changes to on
    Fade lights to 10% in 10 seconds
    Turn off Presentation   (resets the SimSwitch so it's ready to run the next time)

Then you can say, “Alexa, turn on Presentation” to activate the piston.

One small note:
Once a Fade begins, it is near impossible to stop it until the cycle has completed. This is why I only recommend using fades for short durations, if at all.


Checking that right now to see if I am doing it correctly. New to all of this. Thanks


I appreciate your response but I am very new to all of this. If you don’t mine, can you take it a step by step process. I am trying to figure all of this out. I am pretty ok at networking but not on coding. I am not sure which program (website) to use. Thanks again for your help.


Sure thing. I just sat down to a hot meal, so it will be about a half hour.


Enjoy. I am in the US and just got the kids to bed. Take your time. If we don’t finish this tonight, I will be checking in the morning. I need to try to wrap up this project for our new office.

Thanks again.

  • I use a PC browser to go to the IDE. (
    (You might need to use a Private Window in Firefox / Incognito Window in Chrome)
  • Log in and go to “My Devices” (you should see everything you own)
  • Click on “+ New Device” in the top right

Here is my recommendation to create a Simulated Switch.

The Name & Label can be whatever you want, but the name you choose here is what Alexa will use in your spoken phrase later. Also, “Device Network ID” cannot have any spaces. The “ss_” at the beginning is so all of your future SimSwitches are grouped together.

After your device is created, you should see it in the list found on “My Devices”

To get Alexa to see the SimSwitch, just say, “Alexa, discover my devices”

To get webCoRE to see the SimSwitch, load the SmartThings app on your phone, and then:
Automation > SmartApps > webCoRE > Settings > Available Devices > Check the new SimSwitch and Save.

At this point, the next step is to create the piston based somewhat on my last post here.
You can test the piston by saying, “Alexa, turn on Presentation”


Ok… Thanks


I got everything to work all the way to Automation > SmartApps > webCoRE> Settings > Available Devices > Check the new SimSwitch and Save.

I looked in my phone app and I don’t see webCoRE as an option. I have downloaded the webCoRE app. Both App and Website are asking for a code. What am I missing? I hate asking so many questions. Thanks