WebCoRE logging to Google Sheets with multiple tabs


#23

It may be my programming, but it appears that the new write script is writing blanks to the sheet. I’ll continue to debug. Please check my syntax.

image


#24

Sorry, for the overwrite script, the parameters are: XtabX, Value, colName, colNum, and rowNum. You can specify either the column name using colNum or column number using colNum but not both. If colNum is supplied, ColName will be ignored. So I think the parameters you want are:

“&XtabX=Sheet1&colNum=1&rowNum=” Row_Number “&Value=” Foods[$index]

or

“&XtabX=Sheet1&colName=Fruit&rowNum=” Row_Number “&Value=” Foods[$index]

Either should work.


#25

@Pantheon, NOTE: Right now I am having trouble reading anything from google sheets using my script. Seems to be a redirect issue with the latest webcore update. Writing still seems to work fine.


#26

That explains a few things. I appreciate all of your help!


#27

@guxdude, this project is awesome. I am going to be able to use your scripts to do several things. However, at this time, my READ is working, but my WRITE is not. It is probably related to the redirect issue you mentioned.


#28

Which write are you having trouble with? The one to overwrite a cell or the one for general logging that just adds a new row each time?


#29

My OVERWRITE is not working. Not sure if it is my syntax or not. I have tried multiple iterations of syntax in the OVERWRITE script and nothing seems to work. My READ and WRITE work fine.


#30

Here is an example set of arguments from a piston I use:

?XtabX=NWS Temp Records&rowNum=37&colNum=10&Value=2021

This overwrites the value ‘2021’ in row 37, column 10 in the tab ‘NWS Temp Records’. Sorry in my examples above I started with ‘&’ but the first parameter always needs to start with ‘?’.


#31

GIANT applause for you!! The “?” did it. It’s working now. Thank you very much my friend!


#32

So you are not having any trouble with the READ? I keep getting back null due to a redirect that webcore is not following. That is causing all the values I am trying to get to always be zero.


#33

Today my READ is working well. And a BIG thanks to you for all of the work and help here. This is going to allow me to do some things that I have wanted to do for a long time!


#34

You are on ST, right? I wonder why it is working for you and not me.

And you’re welcome. glad others are using it. Spent a lot of time getting these scripts working.


#35

Yes. I am reading, editing and writing a music playlist. I have to put a 3 seconds wait in the write routine and it still does not finish 120 song titles before failing.

EDIT : I made the wait 4 seconds and the script finished. It took over 11 minutes to write 120 song names to my Google Sheet.


#36

How about an entire column?


#37

Never looked at that. I don’t remember the problem I had but once I figured out the replace by cell it was good enough for me. When I have some time I might look at it again. I actually would like to combine all three of these scripts into one. Maybe with a command parameter like ACTION=[READ, WRITE, or REPLACE].