webCoRE Optional Update v0.3.111.20210130


I posted this over on the Hubitat forum but the same thing is happening on SmartThings too.
I have discovered a new issue that cropped up in the past few days. I don’t think the issue is with the app but the recent change made to the dashboard.

I have included screen caps to show the problem but when testing my apps the variables that the app uses would update in near real time. That no longer happens. If I want to see any changes to the contents of a variable I must refresh (F5) to see them.


Heh thanks for copying the post, I’ll copy the response :rofl:

Excellent observation, please try the fix on staging.webcore.co (if you’ve used that before you will need to hard reload the page). The fix is on GitHub, file dashboard/js/modules/piston.module.js in case you run a local dashboard.


Tested on staging.webcore.co and it is working correctly. Thank You!


Published for dashboard.webcore.co, no app updates required.


I just got around to making the changes on my local Pi server and it still doesn’t update the variables in real time.

I did the following;

  • stopped the apache web service
  • Did a “git clone https://github.com/ady624/webCoRE” which loaded the new copy.
  • Restarted the apache restarted the apache web service.

New new version loaded and working but there but still no real time update of the variables.

So I stopped the web service and reloaded the original dashboard I was using before updating to the new one, and it properly updates the variables in real time. It even started complaining about a newer version being available. So I’m not sure if I am doing something wrong or the update you made didn’t quite go right. It’s not a big rush, whenever you have a chance. Thanks.


It sounds like you cloned from the master branch, the variable fix is only on the dev branch at this time. Try git checkout --track origin/dev


How do I get the variables to update in real time again?
Edit- F5 to hard reload and get rid of UI update banner! Again!
Edit- STILL having to refresh page to see variables change.


Thank you. I switched over to the dev branch and its working again. All is good!


I am assuming this is related to the update, as everything was working fine until then…on ST, I have a piston that sends a GET request to an ESPN API pulling various data points for score alerts, etc. It is a large piston ~20 chunks. I am now getting httpStatus of 408 (timeout). Turning on full logging shows that it is working, parsing data upto a point when this error drops:
physicalgraph.exception.DataCharacterLimitExceededException: Handler data length (191431) cannot be greater than 2500 characters. @line 1155 (processSchedules)

Is it just that I am processing too much data at one time, I tried a Clean up and rebuild data cache thinking some data might be stuck from previous calls. Any ideas?

I should note that the API endpoint is readily retrievable via postman (or even directly in a bowser).

Large web request responses error out if response is slow

I spun off a separate topic; this will require more discussion.


Using Chrome desktop and mobile it’s become rather annoying not having local variables update within the piston in real time (piston state updates correctly), now I have to guess what the variable should be or refresh the page.


Since the main problem has been fixed please provide more information so that someone can help you. What type of variables, what type of values, by mobile do you mean in the webCoRE app, ST app, or a browser? You are no longer seeing the upgrade banner after all the refreshing? Where do the variables not update - on the piston page or in the editor?


Hi @ipaterson, I’m going to persevere like this, and first see if anybody else has similar issues, thanks.


Great update.

I was not able to see that the was open/closed issue was resolved in this release, can anybody confirm this?

Here is more information: Problem with Sensor Was Closed At Least X Minutes



Just to let you the dashboard error message is still appearing (at least in iOS app) and as you can see the location mode isn’t populating.


i am not seeing that in my iOS apps


I haven’t seen that either, but have you logged out and back in?


Thanks for the recent updates!

I have quite a few pistons on hubitat, most of which I’ve had from day one since smartthings. At some point recently, one of them has stopped working properly.

Basically, we have a dimmer on the main lights in the Frontroom. When the level settles, I set a variable with that value.

After a 2 sec delay, if this value is brighter than x, then my mood lights turn off. Dimmer? They turn on.

I’ve noticed that recently the Piston works up to the point of storing the settled dim level value. But fails to take the on/off actions following this.

I’m assuming it’s due to an update.

Any ideas?


Same in Android


Is this still a separate, enhanced branch, or has it been subsumed/superseded by the primary branch?

I do see that it seems like the primary one has a higher version number, but I didn’t want to assume (I’m enough of an @$$ already :smile: ).