Advice on if I wasted money


I brought the tp link Kasa smart plugs that monitor energy.

Smart things recognises the plug but not the energy monitoring feature, am I doing something wrong or does anyone know how to get smart things (especially WebCoRe) to recognise and react to the energy monitoring function?

I want to have my lights turn off once my TV turns on (based on powerdraw as my TV is on a powerboard that is always on)

Edit: I didn’t notice my phone changed money to monkey. I guess I should have read everything carefully before posting


This may be worth a read

From a quick scan,it sounds as though callback was added, but only from the new app. I’d guess power reporting would need callback.

Have you tried setting up from the new app or classic? Sounds as though it should work from the new app.


A monkey should never be wasted. :sunglasses:


A “monkey” in some English dialects is £500, so I don’t think you’ve wasted a monkey.


Interesting comment. So does the capabilities that WebCoRE sees depend on both the DTH and SmartThings recognizing the capability? Does WebCoRE get all communication through the app or does the app just provide permission to talk to the device?


I think in some cases it does. I added a sonos after the official sonos support was added. When I changed the DH to the one used by existing speakers, it wouldn’t work, although previously setup sonos’s did.


So @Terminal’s or my previous comments weren’t interesting in and of themselves? Interesting.


Hmmm… Wasted monkey? Now I can’t get this image out of my head…


I was waiting for something like that. :laughing:


I tried in both apps. I can get smart things and webcore to recognise the switch part perfectly. It’s just neither the new app, the old app or webCoRE can see the energy readings (which is why I got that plug the hs110)

The HS110 is a supported device in smart things. I just don’t know how to view or see the energy side of it for the animations I want to make


You keep mentioning you want “energy”, energy is kWh, what I think you actually mean is power reporting which is Watts. If you write on the ST thread linked to above, and speak to Gutheinz, he will give you the answers you seek.


have you tried looking at what attributes it has? In an expression box just start typing


Then list of attributes will pop up. I often see many more than are valid but if I pick one that is not valid it lets me know. Not sure if the value you are seeking could be under ‘level’ or ‘power’ or ‘value’ or some other attribute. Try them and see what is reported.