Alexa and Sonos - Audio actions in routine is not supported on this device


Let me add to the above post for clarity. Alexa Routines will work on one of Amazon’s own echo devices. However, having one in the house will not fix any issues with Alexa routines on the Sonos devices.

I believe full routine functionality will be available on the Sonos One in the very near future, but I am not an insider and can only go by whispers and rumors.


Does this mean that if I have an Echo Dot in my kitchen and a Sonos One in my living room, I still would get the “audio device…” announcement whenever I speak to Alexa from the living room?


Actually, I need to back up as I did some testing this morning and realized I had missed something important in your original post. My apologies!

You mentioned that you has used a momentary button tile as an intermediary. Try changing that to a simulated switch. If that works, as it should, simply revise your piston to turn that switch off some time after it’s been switched on, perhaps once the door is confirmed to be opened or closed.

Just for background, the “Audio Actions not supported on this Device” is intended to prevent Alexa from acting on certain devices that could create security and/or safety issues. For example, you don’t want a burglar to be able to yell through the window to shut off your alarm or open your garage. The way around that, which you tried, is to use an intermediary switch, but for some reason Alexa (this has nothing to do with Sonos) doesn’t like the momentary button tiles in ST.

Sonos One’s support of Alexa routines remain imperfect, but in this case the error is mine in not noting your use of the momentary button tile earlier. Sorry to have misled you.

Please let me know if this resolves your issue.


Actually most of my switches are simulated switches :confused: It`s the original DH from ST, created in IDE.

I have tried with:

  • Momentary Switch
  • Simulated Switch
  • Any Smart Home Device (from Alexa devices)
  • Report Weather (within Alexa, no externals like WC or ST)
  • Calender (within Alexa)
    And more

No mather what: “Audio device in routine is not supported on this device”


Hmm, it’s working here and I’m out of ideas. I’m following your post in the Sonos Community as well, hopefully they’ll be able to do better than I have. :thinking:


Is your setup only Sonos One, or do you have Echo devices as well?

I ordered an Echo Dot just now, hoping this will help with the field in picture below. Perhaps that will solve it. For now I think I will circumvent this by using something like IFTTT.


Why not create a Simulated Switch, and ask Alexa to turn on that SimSwitch.

Then you can program webCoRE to monitor that SimSwitch, and basically program your ‘Routine’ right there in the piston. By avoiding Alexa’s routines entirely, this should bypass the audio error.


@mrhaugland A couple of thoughts

  1. If you prefer, you can turn off Alexa’s replies like the ‘ok’) to most actions (like turning on switches) by enabling Brief Mode. This won’t prevent error messages, however. If you use IFTTT, Amazon recently disabled the “sending that to IFTTT” response that was so very annoying.

  2. You’re probably aware, but remember when editing an Alexa Routine to wait a minute or two after saving it before testing as it takes a bit for the servers to catch up.

@WCmore As noted above, the advantage to using Alexa Routines (or Google Assistant) is that you can create command phrasing that is much more natural, which makes voice control easier, especially for others in the household. Currently, to operate my Garage Door I have to say “Alexa, turn on Garage Door” or “Alexa, turn off Garage Door.” My wife can never remember which is which and therefore doesn’t bother with it. (At one point I used a simple toggle, but that created some safety concerns that weren’t acceptable to me).

Now that Alexa routines are at least partially functional, I’ll probably move away from the simswitch.


Ahh yes, good point. I just though it would be less hassle and quicker responses if we keep IFTTT out of the equation. Either way will work, but they each have their own limitations.


Okay, after further testing and investigation, I can see that there is an issue with the combination of a Sonos One, Alexa Routines, and any simulated or virtual switch in SmartThings.

Bottom line, an Alexa Routine that invokes a simulated switch will work without any problem on an Amazon Echo device. However, while an Alexa Routine that invokes a simulated switch WILL work on a Sonos One, it will not do so without the “Audio actions and routines are not currently supported on this device” error message.

Again, Sonos has not formally announced support for Alexa Routines, so hopefully this will be addressed in the near future.

P.S. I see similar behavior on the Sonos One with weather and calendar, but not real switches and such from ST.


Cross-posting back from the Sonos forum, I replied to your post there.

I just did some further testing based on your reply, Master T.
If I tell Alexa routines to control a scene (which is a ST routine), then she replies with “ok”.
If I till Alexa routines to control anything else, be it a simulated switch, and actual Device (a real switch), weather, calender etc., then she replies with “audio devices in routine is not supported on this device”.

Will test this further when I get home from work.

Telling Alexa to turn on SimSwitches directly will work, but is not natural. Especially when english is not our first language. Example: “Turn on Bedtime” is unatural.

Including IFTTT is actually better then directly turning on SimSwitches. “Trigger Bedtime” will work for me, but not for my wife. Also including another party in the equation is not optimal.

Perhaps this thread should continue only on the Sonos forum, to avvoid cross-posting?


Yes. It’s clearly Sonos-related, not webCoRE. I’ve answered your post there.