Alexa and Sonos - Audio actions in routine is not supported on this device


Bought Sonos One the other day, my first Alexa product.
I have Alexa Routines which trigger on or off virtual switches, which then triggers pistons in WebCore.
This works, but everytime Alexa pronounces that “Audio actions in routine is not supported on this device”.
Is there anyway to get Alexa to not say this?

Webcore + Sonos One - Text to Speach

It sounds like you need to remove any voice commands from inside the Alexa Routine.
(and let webCoRE handle all of your speech outputs)

For more info, you could create & test a new Routine in Alexa with only one command.
(text to speech) This can help you narrow down her capabilities outside webCoRE.


I currently only have two routines, and within each the only thing Alexa does is turn on a momentary switch. This in turn triggers a specific piston.


Ugg, I was afraid of that. It sounds like the age old issue of too many devices rolled into one.
(like the TV/VCR combo in the past had it’s limitations)

I think we need someone that owns that device to shed a little light on this…

One quick question though.
Entirely outside of webCoRE, can you tell Alexa to turn on a lightbulb by name?
Does she give the same audio error?


No, outside of Webcore she acts fine. Its only when including pistons.


OK, I am confused now. In another post you said a simple voice command from webCoRE to the speaker now works well. In this thread, you said that speaker can turn on/off normal lights without an error. There is something else creating the audio error.

Can you be more specific as to what else I am unaware of? Maybe try to recreate the error with as little variables as possible. We need to narrow this down


Yes, I can see how you are confused.
What I meant with “its fine” in the other thread was that “text to speech” is now working.
But Sonos / Alexa is still saying that “audio device in routine is not supported on this device”.

In other words, she first says “audio device bla bla bla…”, then my “text to speech” input afterwards. My aim with the first post was to get the “text to speech” input to work, not adress this issue :slight_smile:

But I must correct myself! “Audio device bla bla bla” only comes when trying to run routines from Alexa. Doesnt mater what the routine specifies what she should do. If I tell Alexa to turn on a specific device (in other words, not to run a routine) she does this with replying “ok”.


If the only audio error comes when running Alexa’s Routines, it sounds like webCoRE has no bearing on it, and cannot resolve it. I would switch focus to try to get a simple Routine working that is entirely outside the webCoRE ecosystem… Once you have resolved that, we can take it to the next level here in webCoRE.

This next idea doesn’t fix the issue, but circumvents it nicely.

I recommend creating all your scenes (programming) in webCoRE.
You can always use Alexa as a verbal trigger, since she handles that part well.


The Sonos One is an ‘Alexa-enabled device’ and like all such devices does not fully support all of the Alexa functionality that is available on Amazon’s Echo Devices. Amazon, Sonos and other manufacturers of Alexa-enabled devices are working to enable whatever functionality Amazon will allow the devices to use, but it’s been a rather slow process.

Alexa Routines are one thing that are not fully supported by the Sonos One as yet. See this post or better yet this more recent one for the Sonos Beam. It used to be the routines wouldn’t work at all, but now they sometimes do, but that annoying notification is still there because some functionality is missing.

The alternative is to create a SmartThings Routine that does the same thing, or skip the routine entirely and give the command directly to your momentary switch. The only downside to this is that the command language isn’t quite as normal. “Alexa, turn on Garage” or “Alexa, turn off Two-Car Garage” just doesn’t roll off the tongue quite as naturally.


Isn`t this what I have done?

My Alexa Routine simply turns on a virtual switch.

I have tried setting up the Alexa Routine to turn on a device in Alexa. Same thing.


Yes, but your virtual switch brings webCoRE into the equasion.
Try a routine that turns on a switch not connected to webCoRE.
(such as a new Simulated Switch)

So far, everything is pointing it to an Alexa / Sonos limitation, but by removing webCoRE from the equasion, it will either confirm or disprove.


Yeah, I have tried that as well.
Making it turn on a virtual switch not connected to WC.


And that simple test still failed?
If so, then you should check into Alexa / Sonos bulletin boards for possible workaround.

Maybe start with @bthrock’s links above


Yeah, will do that.
Thanks for your help.


This is a an known Alexa / Sonos limitation, as I posted above.

Edit, NVM … you saw that.


I appreciate the input greatly.
I know it’s too late now, but I tend to recommend avoiding Sonos with the current limitations.


Yeah, thank you for the reply as well :slight_smile:


I have six Sonos Ones plus three echo devices scattered throughout my house (some in pairs for sterieo) and recommend the Sonos One highly. I didn’t in the beginning, but the remaining limitations are so few and so rarely affect me it’s not an issue anymore. But individual needs and preferences are going to vary.


Could the issue be solved by having an Echo device like the Dot someplace in the house? That way there should be a device on which audio actions in routine is supported on…