Are you a Newbie, this is your post


#21

Hi @ike2018,

Tried to keep it simple with just the motion but it still does not work.
Thanks for the Task Cancellation policy tip, I tried setting as per your advice but the bulbs still turn off as below:
Bulb 1,2,3 - after 15 secs
Bulb 4 - after 55 secs (15 + 40)
Bulb 5 - after 105 secs (15 + 40 + 50)

I am expecting:
Bulb 1,2,3 - after 15 secs
Bulb 4 - after 40 secs
Bulb 5 - after 50 secs
irrespective of other bulbs having their own wait times to turn off


#22

In my experience, “color change” causes delays. Maybe you are having the same problem???

Note : Triggers first, condition later. Swap lines 18 and 20


#23

and let me ask you, why are you using WAIT?
I don’t what you want to accomplish but maybe STAYS INACTIVE would be better in your case.


#24

If you need that, you can set the first two of the tasks to run asychronously (it’ll be in the same place where you set the TCP). That stops the wait delaying the next task.