Automatic Backups


I used the import from backup file to migrate my pistons from smartthings to hubitat. This didn’t set the automatic backup option. I have tried to go in to each piston and enable this option which it seems to do without any problems. However when I go back into each piston the automatic backup setting is no longer enabled.
Anyone any ideas?
Thanks in advance


I am not sure if this works on Hubitat, but in webCoRE you can:

  • Create a blank piston
  • Make sure Auto Backup is set to ‘yes’
  • Click ‘Create’
  • Wait a few seconds
  • Click ‘Delete’

The Auto Backup should default to ‘yes’ for all new pistons you create.
(although each old piston should retain their previous setting)


This is happening for me too. I recently migrated from SmartThings to Hubitat, and created/recreated/imported a bunch of pistons.

For the various pistons, I’ll tap the “Enable automatic backup” button, it will appear to succeed (giving me the bin code), but upon refresh when I come back, the “Enable automatic backup” button is present again, indicating the backup setting didn’t stick.


Can this be done prior to importing the backups?

I’m asking, because I’m about to jump ship with SmartThings as well. The only thing I’m waiting on is ActionTiles to finish their integration with Hubitat.


The workaround above is just to force the web browser to remember that new pistons default to:

In reference to backups prior to jumping ships, here is my advice on that.