Broken Piston - virtual switch


1) Give a description of the problem
Until around 10 months ago this Piston was working perfectly, and then it just stopped. I never had the chance to look into it, and now that I am I cannot work out what is wrong with it. Please can you help?

2) What is the expected behaviour?
This is a simple piston to open a virtual switch (contact sensor 10 in the screenshots) when SHM is disarmed, and I have another piston which closes the virtual switch when SHM becomes armed. I use this to create an announcement from Alexa so I know the alarm has armed/disarmed. These pistons both worked fine for years, and then suddenly both stopped working.

3) What is happening/not happening?
When I test the piston it says it has properly executed, but the state of the virtual switch does not change

4) Post a Green Snapshot of the pistonimage

5) Attach logs after turning logging level to Full



Ah, such a simple little thing, I’ve fixed it with a virtual switch. Thank you!