Cant create webCore backup using safari


I’ve just tried to take a backup of all my pistons after making a few changes. As usual, I tried this using safari on my ipad. It runs through counting the pistons to backup, then asks for a backup password, then opens a new tab to perform the save. But the save doesn’t happen, nothing appears in the tab.

I tried logging out of the dashboard, but that didnt help. I tried a backup using edge on my PC, and that worked fine.

I’ve just tried it using chrome on the ipad, and that seems to work also.

Restarting the ipad didnt help. I’m wondering if it could be thee file size? I have 50 pistons, and the backup is 730kb (which doesn’t seem that large to be an issue)


Does anyone else use safari?
I’ve just tried again and get the following

Safari cannot open the page
The error was: “The operation couldn’t be completed. (WebKitBlobResource error 1.)”


adding @ipaterson


Safari has a privacy preference to allow you to limit which sites can download files to your machine, that permission may have been denied. It’s easy to do since the prompt appears only once and is automatically shared with other Apple devices. From desktop with the dashboard open you can go to Safari > Settings > Websites > Downloads and select “Allow” or “Ask” for the webCoRE dashboard.

If that is not the problem, please try backing up a subset of your pistons to see if not the download size but rather the data in a particular piston is causing problems. That seems unlikely but would be great to know if there are any problems!


Sorry I misread, which version of iOS is your iPad running? Settings > General > About > Version


I’m running the latest ios 16.3.1. I’m not sure if the problem started after this update (from 16.3.0)

I tried a backup of 1 small piston, & still get the same error, so its not looking like a size issue.


I upgraded to test it out. It was working on iOS 16.2 in Safari and Chrome, a prompt appears to download or view the file then the browser shows a download icon. In iOS 16.3 there was no download confirmation in Safari, just the prompt to view or download followed by no confirmation. The file is still downloaded for me however so this may not be what you’re experiencing. I’m not accustomed to a new tab opening to perform the save, was that also happening when your downloads were working?


On IOS, a separate tab has always opened, and then the download icon appeared on the menu bar. However, now, I just get the new tab, with the error in the main browser window, and no download button. I’m not seeing the download file created.

Are there different methods to download available via the api? I downloaded an update for my plex media server on the same ipod, and that never opens a new tab - and still works.


The backup file is generated on your device in the browser and then offered up for download so unfortunately there is no backup API. All I can say is that it works for me so possibly check if there are any ad blockers interfering, browser privacy settings, or if it works in an alternate mobile browser like Firefox or Chrome.


I d use adblock plus, but its never caused any issues. I’ve tried turning it off and it still doesn’t backup. On one occasion, I did get the backup of the piston displayed on the screen, rather than giving the download option. But I cant get it to do it again.

I’ve tried in chrome, nd that seems to work fine.

I’m not aware of any changes on the ipad which could have caused this. It’s quite a static platform.


I’ve just tried on my partners ipad (same ios & adbloclplus) and it works fine. On checking all safari settings the only one I had different was block pop ups (which sounded hopeful) However, it made no difference. I also deleted all safari data for webcore, and still no difference.

I must be missing something, but have no idea what


I’ve found the issue!

A few days ago I pinned my WC dashboard tab as I keep accidentally closing it. Un-pinning it resolved the problem. This looks like a safari IOS bug.

Thanks for your help with this, If anyone else arrives here, try unpinning the WC dashboard tab.