Chart Error When Selecting Data Source Type


1) Give a description of the problem
I’m trying to create a chart with WebCoRE but getting an error when I select the data source type. The error is “Error: Cannot get property ‘id’ on null object”

2) What is the expected behaviour?
I want to chart out the temperature set points and temperatures from each of my three Midea AC units. They’re controlled via Hubitat using the tomwpublic/hubitat_midea ( custom driver.

3) What is happening/not happening?
I get the error when I try to select “sensors” as the source type.

**4) Post a Green Snapshot of the piston!

5) Attach logs after turning logging level to Full
[app:273]( 11:48:37.379 AM[error]( Cannot get property 'id' on null object on line 872 (method deviceSelectionPage)


would need to see the settings for that chart app

Did you have an older sensor in there and re-create the sensor (or delete the original sensor?)

was there any further information in the logs or stack trace?


1.I’ve attached a screenshot of the settings page.

  1. No, I’ve never been able to complete the setup of the graph because of this error. I’ve tried creating a graph with other devices and the issue is the same.

  2. Here’s a screenshot of the logs of the latest attempt:

Thanks for your help!


More info: If I create the graph without selecting the “source type” it will not give me the error, but then when I try to view the chart/graph, it gets stuck on drawing chart 4/4.


are you showing all of the settings?

Why is there an quant setting enabled?


Also, are you really wanting to use a timegraph vs. timeline?


I’ve tried creating a “time line” and a “time graph” and I get the same error either way. I’m not sure what a quant setting is. :confused:
Thank you for trying to help!


I sent you a private message, can you reply to that?


This issue should be fixed in latest webCoRE (if user install)

Not sure HE has pushed this update yet to general firmware. WebCoRE HE versions should should April 15th or later


It’s working great now! Thank you so much!