Connector Variable Stopped Working


I’ve just noticed a connector variable which is set by a piston & displayed on the HE dashboard is showing a value of null.
The piston has not changed, and the variable assigned to the connector is not null. I updated WC via HPM this evening, and am wondering if that has introduced a bug?

I’ve just tried a new simple piston using the same variable, and it also doesn’t work. If you set the variable in HE, when you run the piston, the value changes to null, rather than the correct value.

01/02/2023, 21:11:27 +179ms
+8ms ╔Received event [Home].test = 1675285887179 with a delay of 0ms, canQueue: true, calledMyself: false
+16ms ║RunTime initialize > 16 LockT > 0ms > r9T > 7ms > pistonT > 6ms (first state access 2 m:9 8 8)
+18ms ║Runtime (5517 bytes) initialized in 7ms (v0.3.114.20230130_HE)
+20ms ║╔Execution stage started
+236ms ║║Executed device command [SensorStatus].setVariable(null,test message) (210ms)
+238ms ║╚Execution stage complete. (219ms)
+242ms ╚Event processed successfully (234ms)


The resolution to this is a piston change (due to a webCoRE change):

(Choose the custom command setVariable)

result will look like:


Piston not working anymore, "null" that I do not understand

Thanks. That’s resolved the problem. The new method does look better & more intuitive.

Piston not working anymore, "null" that I do not understand

@E_Sch I am seeing strange behaviors on Pistons since the last week or two related to a variable. These pistons have worked for years and now all of a sudden an issue.

Even when the GE Motion/Switch is NOT turned on physically, the variable I have circled below still evaluates as true. Any ideas?

I see in the response you have above to @Paul1964 ‘Choose the custom command setVariable’, but when I try to edit my piston there is no custom command for setVariable, only location command.

Below is a screenshot of the log that is the issue. WebCore receives the event that the motion has stopped and it evaluates as True Group 9 & Condition 10 which is that the switch has “physically receives ‘on’.”





I dont see SetVariable under commands available to all devices. What am I missing?

Not sure if that would even be the issue. Why would the Piston suddenly evaluate on a ‘motion inactive’ event that the switch has been physically turned on, when it never did before ~two weeks ago?


Try using for your IDE

Are you up to date on HE system / webCoRE version.

You should see the custom


I tried the site as my IDE. I am up to date on HE and Webcore firmware/updates.

I still do not see setVariable as a custom command available to all devices. What else could I be missing?

when I use the setVariable command in the list of location commands, it does not give me the option to give it a value like I could in the IDE.