Deleting a Failed SmartThings Device


Description of the problem
Unable to delete or force-delete a Honeywell SmartThings plug-in switch.

What is the expected behaviour?
Expected delete and force-delete to delete the device.

I deleted the device from the webCoRE SmartApp.

What is happening/not happening?
Z-Wave exclusion error for delete: “The device was not deleted. Try following the mfgr’s instructions.”
Z-Wave exclusion error for force-delete: “This device can’t be deleted because it is operating normally.”
In webCoRE, the error says "This device is used by the following SmartApps:
webCoRE / webCoRE (dashboard)
webCoRE / webCoRE
“Deleting the device will remove it from all SmartApps, which may cause some of them to no longer function.”


  1. Do I need to do anything to remove the device from the two SmartApps before I can delete the device in the SmartThings app on the iPhone?
  2. If I delete the device in the IDE, will webCoRE or webCoRE Dashboard stop functioning correctly?

I haven’t yet tried deleting the device in the IDE.

  1. I can’t remember as I no longer use Z-Wave but I suppose it is possible. Just go into the webCoRE smartapp in your SmartThings app and delete the device from Available Devices and it should be gone from webCoRE. Then it will be moot.
  2. No, you should be absolutely fine. But as in 1) you can remove it first and it won’t get the chance.


I had already stopped making the bad device available to webCoRE in the SmartThings app. That removed it from webCoRE. BUT, in the IDE, I still see:
In Use By:
• webCoRE / webCoRE (dashboard) (webCoRE Dashboard)
• webCoRE / webCoRE (webCoRE Storage)

Maybe it isn’t a problem that the bad device is still in use by webCoRE Dashboard and Storage?


I deleted the device in the SmartThings IDE and that seems to have solved it (it’s gone from the ST App now). I doubt that I will have any problems with webCoRE Dashboard and Storage (fingers crossed on that).