Echo-speaks devices in webCoRE


I suspect I’m missing something really obvious. I have installed echo-speaks in ST (classic) app. It works fine. But I don’t see my Alexa devices in webCoRE. All the examples I’ve looked at refer to “music player.” How does an Alexa device become a “music player” in webCoRE? Thanks.


Did you add the Alexa Devices to Webcore under Automations in the SmartThings App? You need to do this before you can access them in Webcore.


Thanks for the quick reply. I suspect this is the step I’m missing. How do I add the “Alexa Devices to Webcore under Automations in the SmartThings App”?


Quick link


Right. So, may problem may be a bit tricker. I don’t see my Alexa devices in that list. I have dozens of devices there, but my 4 Alexa devices aren’t amongst them!


There are multiple categories there… Not sure which one is for Alexa Speaks.
Try looking in a few different ones


First, are you using the ST Classic app?

Open the app.

Tap on Automation at the bottom.

Tap your WebCore Smartapp
Tap Settings
Tap Available Devices
Tap Available Devices again on the next page
Tap Select Devices by Capability
Scroll down the list and add Echo devices where applicable.
Tap Done at the top and back out of the SmartApp

I’ve added mine to multiple categories.


Thanks. I found it! In the ST classic app, one has to scroll to the bottom of the “available devices” to “Select devices by capability” and then scroll down to “Which music players”. Select, chose the relevant device(s), and then save. Those devices are then available in webCoRE.


For whatever reason my is not showing any tips how can I add ?


First, charge your phone. :stuck_out_tongue:

Next, try these steps. Go to Smartthings

Slowly click Done and Save several times until you exit out of Smartthings.