Echo Speaks - Fire Alexa Routine from Webcore


#1

1) Give a description of the problem
I am trying to get webcore to activate an alexa routine using the executeRoutineid(…) variable

2) What is the expected behaviour?
at a certain time of day, an alexa routine should fire.

3) What is happening/not happening?
I Can’t figure out what to put in the text executeRoutineid(…). if i put the routine name in there, it does not work.

4) Post a Green Snapshot of the pistonimage
(UPLOAD YOUR IMAGE HERE)

5) Attach logs after turning logging level to Full
(PASTE YOUR LOGS HERE THEN HIGHLIGHT ALL OF THE LOGS AND CLICK ON THE </> ICON TO FORMAT THEM CORRECTLY)

REMOVE BELOW AFTER READING
If a solution is found for your question then please mark the post as the solution.


#2

Unfortunately, webCoRE cannot communicate directly with Alexa…
(perhaps you are using Echo Speaks to try to get around this?)


#3

Yes i do use echo speaks and it works well with the alexas and webcore but i can’t figure out how to get an alexa routine to fire from a webcore piston. there is an option that said executeRoutineid(…) but i do not know what to fill in for the routine id.


#4

I will add “Echo Speaks” to your title here, to give you more exposure.

Unfortunately, I could not find any reference to executeRoutineid on his webpage.


#5

Here is a quote from tonesto7:



Note: That link above only works for me if I log in first.


#6

Thank you

I did see that note and i logged into the site but i’m not sure where to locate the routineid. I don’t see anything in there that says routine id, i see customer id but not routine. Thank you for you help


#7

I have seen many references made by tonesto7 saying basically this element may be hard to get into webCoRE… but in September, he also said, “This item is now possible using the new Actions companion app in v3 beta”


#8

I assume the companion app he’s referring to is the echo speaks smart app?


#9

Not sure, I use a different method for Alexa integration.


Side note:

I just found a quote from napalmcsr:

  • go to this link
  • log into amazon in that link.
  • wierd file shows up, copy to notepad
  • go to one of your new echo devices in hubitat
  • find the executeroutineid in the device
  • search the notepad file for the routine you want. there will be a couple routine ids for that routine. I kept trying the different ones until I got it to work. The logs show an error if you don’t get a good routineid.

#10

oh thank you, i believe i found the id i was looking for called automation id. i put that in there and it does work to run the routine. Do you possible know why all of my routines are not listed in that weird file?


#11

I suspect it only shows routines from that Amazon account… Not routines from SmartThings.


Note: you don’t need Echo Speaks to trigger a SmartThings routine:

pic

That one can be done directly inside webCoRE.


#12

the ones that are NOT showing are alexa routines, it shows most of them but not all


#13

i deleted the routine i couldn’t find and made a new one and it showed up in the api/behaviors/automations site.


#14

I am going to guess that perhaps old (ancient) routines might not have made it over thru all the updates. (IE: internal commands may be worded differently)

Recreating a new routine was going to be my next suggestion. :sunglasses:


#15

Thank you for all of your help!!


#16

Glad to be able to.


#17

To assist others who may find this thread in the future, here is a quick summary:

To use Echo Speaks to fire an Alexa Routine:

  1. Log into Alexa.Amazon in another tab
  2. Afterwards, click --> alexa.amazon/api/behaviors/automations
  3. Gibberish text comes up. Save it to a text file, or clean it up first by pasting it here
  4. Search that text file for the name of your routine. If it’s listed as “Alexa, Quick light”, then search for “Quick light” (you should find it listed as an “utterance”)
  5. Shortly before that, you will see “automationId
  6. Copy the contents of “automationId” to your clipboard
    (IE: amzn1.alexa.automation.734a91be-798e-361b-add4-841e7ae05f8b)
  7. Back in your piston, WITH Echo Speaks, executeRoutineId(…)
  8. Click on Parameters > Add a string parameter
  9. Paste the URL on your clipboard next to Value
  10. Save

pic

Afterwards, every time this command runs, your Alexa Routine will fire.


#18

@WCmore, Awesome! I have been wanting to do this for some time now. I will definitely give this try.


#19

@Ftimpani


#20

Done sorry