Echo speaks stopped speaking


#1

1) Give a description of the problem
My echo speaks service stopped speaking… The Webcore piston is firing correctly, but the Echo Speaks app doesn’t seem to work. I suspect its because the Echo Speaks sService is looking for Echo Server v 2.2.2. However I believe i have version Echo Speaks Server 2.2.1. How do I change that ?

2) What is the expected behaviour?
(PUT YOUR INFO HERE)

3) What is happening/not happening?
(PUT YOUR INFO HERE)

4) Post a Green Snapshot of the pistonimage
(UPLOAD YOUR IMAGE HERE)

5) Attach logs after turning logging level to Full
(PASTE YOUR LOGS HERE THEN HIGHLIGHT ALL OF THE LOGS AND CLICK ON THE </> ICON TO FORMAT THEM CORRECTLY)

REMOVE BELOW AFTER READING
If a solution is found for your question then please mark the post as the solution.


#2

Have you posted in the main Echo Speaks thread in ST forum? You might have to reauthenticate your cookie and you’re more likely to get you detailed instructions from there.


#3

There’s an update to the server and Smartapp.


#4

My Echo stopped speaking working correctly for a long time.
Can you provide more information on the Smartapp update needed to correct this problem?
Thanks, Ray


#5

Same here. Any help would be greatly appreciated


#6

Same problem here. I captured logs from IDE and it does look like a cookie problem. I can’t remember the steps to get this working in the first place, but I @eibyer may be on to something. Going to research the cookie reauthentication now…


1221aa28-4407-423f-90f7-b0b81e1819a5
10:07:25 PM: error java.lang.IllegalArgumentException: Failed to complete. Message was: Read timeout to echo-speaks-nibywbxhv.herokuapp.com/52.6.103.192:443 of 20000 ms @line 1226 (cookieRefreshResp)

1221aa28-4407-423f-90f7-b0b81e1819a5 10:07:25 PM: trace cookieRefreshResp…

1221aa28-4407-423f-90f7-b0b81e1819a5 10:07:05 PM: trace processData Received | Version: 2.2.1 | onHeroku: true | serverUrl: null

1221aa28-4407-423f-90f7-b0b81e1819a5 10:07:05 PM: trace getCookieData() Request Received…

1221aa28-4407-423f-90f7-b0b81e1819a5 10:07:05 PM: debug wakeUpServer Completed… | Process Time: (160ms)

1221aa28-4407-423f-90f7-b0b81e1819a5 10:07:05 PM: trace wakeUpServerResp…

403c5035-12e0-4658-98a7-78d5d1a29570 10:06:30 PM: info ╔ Event processed successfully (190ms)

403c5035-12e0-4658-98a7-78d5d1a29570 10:06:30 PM: trace ║╔ Execution stage complete. (93ms)

403c5035-12e0-4658-98a7-78d5d1a29570 10:06:30 PM: trace ║║ Executed [Echo - Echo - Living Room].playTextAndResume (77ms)

403c5035-12e0-4658-98a7-78d5d1a29570 10:06:30 PM: trace ║╚ Execution stage started

403c5035-12e0-4658-98a7-78d5d1a29570 10:06:30 PM: trace ║ Runtime (38632 bytes) successfully initialized in 61ms (v0.3.10e.20190628) (93ms)

403c5035-12e0-4658-98a7-78d5d1a29570 10:06:30 PM: info ╚ Received event [Button One].button = pushed with a delay of 63ms

4df4d1cd-7f1f-4e7c-ba72-fe08939d129a 10:06:30 PM: warn Amazon Cookie State Values Missing: [cookie:session-id=147-4712800-6259956; session-id-time=2191914951l; ubid-main=132-8188960-5998722; x-main=“NJEhl2kduXX6TmOiWRWiP6VuLq0OUhZL”; at-main=“Atza|IwEBIFtiykr6z9wtMxVrK_VRxgvxBewt8BpmfgAD2pifMJpzQ2VDJHy39W_1MdHxNKWb2SHtfY9GP-LkzoeyWE5pZ2jKWN5YTDVfS5PfZFfT9wygQW_BPGHQpEXZQg_FU4gGttS6hWCeovRlrUV1hrJs1t18OhF1PynXkMrlq1xMCmD_nX1hOZrIGcgIVZ-SRF0CGYVOXjs5rrHHoQQroK0URr2Bvmq472tcAkd9JeaKd8LA5-qSzymPtFNRPG0-i8TXBQM5VpNsa_ZegRd0-pqylI93lxVIadFMtk3h-JIUgPWN_A_gP3M6i0wHrCdW_nBooEjhwC29M5fRH8Fg67v0OU8dpFruMaajqudE7GgTI80z2sve_O_8UpF5_ZC4hfcRIEtwnOuSWFnJSnMMBkYP4Y00GWb5xAlwuDUGuaRQGoYnJzD5J7P-cLPh_HDl1anNvVpbFAKvO1v98s83-x0WYG3cimSeYMk4BYs6P9pXmSmjADvKuxaEfbtyIURzmY3JEdc”; sess-at-main=“UVi54NNZHiIWVEVkwmxOIl8HKR/kB0xgzR7xKlYx/YE=”, csrf:null]


#7

Resolved!! I deleted the server and reinstalled
https://tonesto7.github.io/echo-speaks-docs/#/docs/installation/configuration/serverConfig

In the process I noticed that within the Echo Speaks SmartApp (in the Smartthings app on your phone) there is a “Refresh Alexa Cookie” option within the “Alexa Login Service” section. I wish i had tried this first to possibly save a few steps. I’d be interested to know if anyone tries to simply refresh the cookie and has success.

Good Luck!


#8

I tried the refresh cookie in the Alexa app and it had no effect.


#9

I also tried going to the Smartthings IDE and updated all of the My Smart Thing Apps including Echo Speaks


Still no help.

I looked at your link to a solution and I am a bit intimidated given all of the steps. I was hoping for a smoother path. Thanks for your feedback


#10

Thanks for the updates @RayK18. I tried updating all my apps as a first step as well. I was also intimidated by the steps to remove and readd the server, but the instructions were very detailed and easy to follow.


#11

I hope to have time next week to do the purge and reinstall that you suggest. Has it continued to work after doing this? The reason I ask is some have reported temporary success (with other fixes, not this one) and then have it revert back to being mute. I hope this is the silver bullet.

Thanks for your work on this important matter.

Cheers, Ray


#12

Yes. Still working as expected.


#13

I finally got a chance to apply your fix and I am embarrassed to say that I’m confused with Step 1.

Herok (Server) Setup: is the found in the SmartThings IDE page? There is no link in the document and I’m sorry to not know where to go to start.

I would very much appreciate your help.

Thanks, Ray


#14

Through a very circuitous and unskilled path, I was able, using the motivation from your message, to completely re-loaded Echo Speaks. She speaks again! Thanks.

Cheers, Ray


#15

Great news. Congratulations! I must say I felt the same unease through the process, but was very pleased with the results. It has remained solid for me and I wish you the same long-term success.

-Dan


#16

Where is the directions to update this? I am getting server errors, and my echo speaks stopped speaking as well