getLocationMode() breaks WebCore (edited title 9-8-2020)

piston
bug

#1

A few days ago my classic Smartthings app had issues with classic smart home monitor. It would not show the three buttons to arm or disarm that system. I contacted Smartthings support and basically told me to delete the old smart app.

Fine then. I’ll just build something with webcore then! Or so I thought.

The dashboard normally shows three piston states but instead it shows the above.

I can not edit any of my existing pistons since they were all dependent on classic SHM.

Anyone else experiencing this?

UPDATE 9-8-2020
After migrating fully to the NEW Smartthings app I rebuilt my pistons from a backup. However, this “getLocationMode” issue comes back and prevents pistons from working. Dashboard can accessed but you can’t view any pistons; you just get presented an endless spinner.

Tried to use the Smartthings IDE to delete the smart app to reinstall. Things on the IDE side are ok, but when you go the the smartthings app to install it, I get a pop up saying “Something went wrong. Please try to install the SmartApp again”


#2

I’m not experiencing the problems you see, not least because I delete SHM a while back. However I would note that {{getLocationMode()}} suggests there is more to the story, as that’s the Location mode, not the SHM mode.


#3

In early August this happened again. “getLocationMode”. So I fully migrated to the New Smartthings app and I do not use the old classic app anymore.

I rebuilt my pistons without any references to SHM. Yet the whole webcore seems to be dependent on this “getLocationMode” and if that is unavailable your pistons are lost.

Just today, it happened again. Is this evidence that Webcore is no longer a viable smartapp? Is anyone else experiencing these issue?

Is there anyway to make Webcore not dependent on “getLocationMode”

Is there an alternative to Webcore?


#4

Same problem here. Never had this issue (at least not noticed). Today the dashboard isn’t loading due to “getLocationMode” error and pistons aren’t working.


#5

I am also having a similar issue. Everything has been working fine for months. Today (09/08) it says that there is an issue loading data and it wants me to log out and back in. I have tried that. I get the same message and none of my pistons fire anymore. I, long ago, migrated to the new SmartThings. So I don’t believe that is my issue. My pistons were all working yesterday. I want to say that they were working this morning (09/08) around 6 AM Eastern. When I got home from work…nothing. In the upper left corner it says “\ loading”.