Ghost controlled lights


#1

1) Give a description of the problem
I had 2 standard white smart bulbs running. They were programmed to turn off and on (and dim) using an ikea switch using a webcore piston. Later, I swapped them for color bulbs. In the piston, I swapped out the bulbs that the switch controls. Later, I put the original white bulbs in a closet. The switches still control the original white bulbs, in addition to the new bulbs.

2) What is the expected behaviour?
Only the color bulbs should be controlled by the switches.

**4) Post a Green Snapshot of the piston!

5) Attach logs after turning logging level to Full
2/9/2020, 8:27:26 PM +732ms
+2ms ╔Received event [Upstairs Switch bottom button].button = pushed with a delay of 103ms
+110ms ║RunTime Analysis CS > 20ms > PS > 63ms > PE > 26ms > CE
+112ms ║Runtime (41919 bytes) successfully initialized in 63ms (v0.3.110.20191009) (109ms)
+113ms ║╔Execution stage started
+127ms ║║Cancelling condition #2’s schedules…
+128ms ║║Condition #2 evaluated false (10ms)
+129ms ║║Cancelling condition #1’s schedules…
+129ms ║║Condition group #1 evaluated false (state changed) (13ms)
+139ms ║║Comparison (enum) pushed gets (string) pushed = true (1ms)
+140ms ║║Cancelling condition #6’s schedules…
+141ms ║║Condition #6 evaluated true (9ms)
+142ms ║║Cancelling condition #5’s schedules…
+143ms ║║Condition group #5 evaluated true (state changed) (12ms)
+232ms ║║Cancelling statement #7’s schedules…
+259ms ║║Executed physical command [Upstairs Lamp].off() (20ms)
+260ms ║║Executed [Upstairs Lamp].off (21ms)
+282ms ║║Executed physical command [Upstairs Overhead North].off() (17ms)
+283ms ║║Executed [Upstairs Overhead North].off (18ms)
+306ms ║║Executed physical command [Upstairs Overhead South].off() (17ms)
+307ms ║║Executed [Upstairs Overhead South].off (19ms)
+318ms ║║Condition #10 evaluated false (9ms)
+319ms ║║Condition group #9 evaluated false (state did not change) (10ms)
+326ms ║║Comparison (enum) pushed gets (string) held = false (0ms)
+328ms ║║Condition #15 evaluated false (7ms)
+329ms ║║Condition group #14 evaluated false (state did not change) (8ms)
+331ms ║╚Execution stage complete. (219ms)
+332ms ╚Event processed successfully (332ms)

From the smartthings API, it shows what controls the lights:


And the switch:

Has anyone else had this happen?


#3

I do have the smartlighting app installed, but don’t have those lights configured in it.

For a fun additional test, I just “paused” the piston and tested the switch. The switch still controls the white lights with the piston paused.

Edit: unplugged the power from the hub, the lights didn’t turn on when I pressed the buttons. I’ve seen that you can pair the Ikea switches directly to bulbs, so I wondered if that’s what happened somehow. That didn’t seem to be the case.


#5

Can’t tell from the anonymized piston but did you assign different names to the new color bulbs or re-use names. You mentioned 2 bulbs but this piston shows three being controlled. What is supposed to control the white bulbs in the closet? Any chance of cross talk between the two pistons? This piston only controls one set of bulbs.


#6

The bulbs were renamed, and the new bulbs did take the same name as the old ones.


#7

And no way the closet control piston can get triggered by something in this one?

Maybe a crazy suggestion but try changing your devices in all your with statements to something else entirely (any device, doesn’t really matter). Then save the piston and then go back in and set back to the new bulbs. I have had weird problems when duplicating pistons where I have had to do something like this to clear it up.


#8

I won’t mention any names, but I have seen this happen with multiple clients.
@guxdude’s suggestion should resolve it.