Google relay announcement not working unless tested manually


1) Give a description of the problem
I have a sense device that has finally detected my dryer. I have sense integrated with Smartthings. I would like ti use WebCore to announce when the clothes are dry. If I test this then it announces on my google homes using the relay version 2 and @brayton device handler for the relay ( I’m not a WebCore expert by far and since the update to webcore most of my old announcements now state the piston does not subscribe to any events.

Also I wanted to mention my kid’s are actually young adults so it is ok to curse them at this point.

2) What is the expected behavior?
If the dryer has been on for at lease one minute then google home should announce the clothes are dry.

3) What is happening/not happening?
No announcement is being played unless I do a manual test


5) Attach any logs (From ST IDE and by turning logging level to Full)
( 12/1/2018, 7:42:32 AM +107ms
+1ms ╔Received event [Home].test = 1543668152107 with a delay of 1ms
+275ms ║RunTime Analysis CS > 21ms > PS > 196ms > PE > 58ms > CE
+279ms ║Runtime (40447 bytes) successfully initialized in 196ms (v0.3.108.20180906) (276ms)
+281ms ║╔Execution stage started
+301ms ║║Comparison (decimal) 357.0643005371094 is_less_than (integer) 1 = false (2ms)
+303ms ║║Condition #6 evaluated false (12ms)
+305ms ║║Condition group #4 evaluated false (state did not change) (14ms)
+308ms ║╚Execution stage complete. (28ms)
+310ms ╚Event processed successfully (310ms))



Is Outlet 15 somehow controlled by the dryer?
Or do you have things set up such that someone must flip a wall/smart switch in order to get power to the dryer?

I would try writing it differently. My washing machine is on a smart plug, and it goes like this:

Washing machine’s power was greater than 1 watt for at least 30 seconds
Washing machine’s power stays less than 1 watt for at least 300 seconds
With Echo (various echo devices)
setVolumeSpeakAndRestore (80, “wash cycle is complete”)

It also sends a PUSH notification to my android control tablet.

The 300 seconds is not really a long time, and ensures that it’s not alerting me falsely if there’s a pause while within the cycle. It works every time. Typically dryers do not have a pause, so the 300 seconds could be whittled down to 60 or so.


I will check this out the outlet showing in webore is actually a representation of the power the dryer uses. So I have have sense installed which monitors all my power in the house and over time it starts identifying individual devices and can tell when each device is on or off. I installed the Sense smartapp for Smartthings so each device it identifies shows and reports to smartthings. When I took a screenshot of the piston it just gave it a generic name. For what ever reason I noticed I had to set the power less than 600 watts before it showed true during testing.


I’ve never herd of the Sense smartapp, and do not see it in my automations section… and when I search “Sense smartapp” in the community forum, nothing comes up.
Is it a custom app?
Is there a GitHub repository for it?


This is the sense device. and this is the app I have installed. it runs on a node.js server is a little buggy right now but I’m hoping it improves.It’s a great device and I like that it can identify all devices in your home (Although it takes a lot of time) and adds smart functionality based around dumb devices.If you like controlling automatons around dumb devices and like monitoring your entire power usage it’s a great device. I was planning to buy smart plugs and or individual power sensors for several appliances and honestly when all was said and done I would of probably invested more than I did for this device and still not had the total power usage monitoring I have today.


@Glen_King How do I add this bit to the Piston? I’m just not seeing the options. I’m pretty new to WebCore and beyond basic logic I’m not able to do the more advanced stuff. I was starting to get the hang of it and they did the upgrade recently and it just confused the heck out of me.

or at least 30 seconds
Washing machine’s power stays less than 1 watt for at least 300 seconds

If I click on settings I don’t see a way to the at least 30 seconds.


In the ‘Comparison’ drop-down, if you scroll down you should see options such as WAS greater than.
Click on that, and the “for at least…” field should appear.


Didn’t find was for the first rule. I did find this you think it will work?


@Glen_King Yeah I’m not finding the “was” and the “is less than” is not working for me. I guess it makes sense it’s not working.


Update I got one configured for the washer but not had time to test it fully yet. I also got one for the dryer but for some reason it initiates the command a minute or so after starting the dryer. Then again when it’s complete I will keep adjusting it until I find out a solution. Thanks for all your help @Glen_King two other questions I have is how can I use the adjust volume command with the random command? Also do you see issues with the voice command only being sent to one device on some occasions? Oh I just seen you are using echoes and not google homes. Is their away to set the speaker volume on a home?