How do I register a new instance?


Apologies if I’m missing the obvious but I’m having trouble registering a new instance.

My hub died, I received a new one and I have reset and added all of my devices to a new ST location. Now it’s time to get WebcoRE up and running with the new location but I cannot figure out how to register a new instance. Here’s what I’ve been doing:

  1. Log into the dashboard using a web browser
  2. Select ‘Register Instance’
  3. It prompts me for the SmartApp registration code
  4. I use the Register a Browser option in the iOS app to get a code, enter it and click the arrow
  5. I’m sent back to the dashboard view where I started.
  6. I bang my head against my desk a few times and try again. The same thing happens.

I’m brain-dead from three days of moving devices so I’m probably missing something but I don’t know what it is. Any help is appreciated.



Click on the drop down to see your new instance.


Thanks for the suggestion @Pantheon. I had looked at that but only my original location is shown when I select the drop-down. Your reply reminded me that I hadn’t tried other browsers so I did that but still no luck.



That’s odd. I tried to register a new instance and got the same as you. Only one instance…Hmmmmm.


It worked when I added a second instance to my dashboard. Are you certain you are using the security password you set up for that instance of webcore? You could try resetting the webcore password and then try to register a new instance.


just curious… your hub died and you got a v1 hub as a replacement? why not one of the newer hubs? your last image shows 13.13 firmware which is a v1 hub


Also, it may be worth mentioning that whenever I make any changes to my account or update, I always do a hard refresh in my browser before doing anything else.
(In Windows, a hard refresh is Ctrl-F5 while on the Dashboard)

This clears the cache, and ensures that you are only seeing the current data.


I did that initially, and again. Still the same. Only one instance. It keeps taking me back to the original instance.


No, the new hub is a V3 hub. But you raise a good point. Until the V1 hub died, things were pretty solid so I rarely did updates to any of my apps. I was hoping to not add variables into the mix so I just installed the V3 hub and started moving devices. A WC update may address the problem I’m seeing. I’ll do that in the morning and see what happens.


Great point. I did that and still no luck. Good to remember, though.


I’ve updated, saved and published the most recent versions of WC in the IDE but still can’t register a new instance. I get the prompt to enter a code but just get sent back to the dashboard when I do.


You may need the assistance of one of the webcore minions since you switched hubs.

Tagging @ipaterson


When you ‘Register Instance’ with the webCoRE dashboard in a browser, you are telling it about an instance that already exists and giving it permission to access it. Your description doesn’t mention having created the new instance via the mobile app (i.e. having installed a new copy of webCoRE from the SmartApps menu like you’ve never done it before, named it, set up a password, added devices etc). It just sounds like you are using a registration code from your original instance of webCoRE. As it already has access to that instance, it basically has no effect. You need a registration code from the new instance.

Could that be what has happened? Apologies if you have done all that, it just seemed like a lot not to have mentioned.


You’re spot on. I was approaching the whole thing backwards and thought I needed to first register an instance and then associate WC with it. Thanks for pointing me in the right direction.