How To Troubleshoot when Pistons are no longer running?


1) Give a description of the problem
I have more than 25 pistons running (humming happily). It seems that some are no longer working or reporting via push notifications. I have live logging on, and run tests on the pistons, I can see the true/false on the piston. These are primarily on pistons that have global variables.

2) What is the expected behaviour?
The pistons to work, push notifications to work again, and them to run. The notifications are showing in notifications (messages) but not on my phone.

3) What is happening/not happening?
I am no longer receiving push notifications in a lot of my report pistons. Ex. Piston below was suppose to run at 8:46am and I didn’t receive notification on my phone ( I know a few battery devices are within the thresholds).

**4) Post a Green Snapshot of the piston![image|45x37]

5) Attach logs after turning logging level to Full

5/19/2019, 8:43:19 AM +652ms
+0ms ╔Received event [Casa de Pines].test = 1558280599651 with a delay of 0ms
+318ms ║Runtime (53690 bytes) successfully initialized in 247ms (v0.3.10a.20190223) (316ms)
+319ms ║╔Execution stage started
+349ms ║╚Execution stage complete. (30ms)
+353ms ║Setting up scheduled job for Sun, May 19 2019 @ 10:50:00 PM MST (in 50799.996s)
+373ms ╚Event processed successfully (374ms)


When this happens to me, I open SmartThings on my phone, and make sure I am still logged in. If that doesn’t solve it, I log out of the ST app, and then log back in. This usually fixes the PUSH notifications.


Thanks. I tried that. Still not getting pushes


Can you confirm that in the ST app, the messages are not seen under:
Hamburger > Notifications > Messages


Messages do show. Still no push notifications.


Is this true for all of your devices, or just one?


I’m only concerned with my phone. I haven’t checked any others as those devices don’t have notifications running.


Personally, I think it is worth checking to see if the other devices are receiving notifications, but if you don’t want to check, all I can think of is to reboot your phone, and make sure you are logged into the ST app afterwards.

By the way, the log you posted was not at 8:46am, so it is not helping you troubleshoot…
IE: It will not send a notification when pressing TEST. Only when the time is 8:46


Understood, but my other devices do have notifications turned off. Thanks for the By the way. I have tried throughout the day and no pushes at all but they are showing in the messages/notifications in classic app.


I don’t know how you have yours set up, but on mine, when I send this command:


my Android will read the words outloud, and then Tasker clears the notification from my device.


Usually I do. I used your Tasker trick, but I also have the push notifications coming through normally. Some of the ones I used to use with tasker I dont anymore for a few reasons. Either way, they are not getting to the push on Android regardless.

Futhermore, it doesnt even get to Tasker since there is no notification to run through the tasker St_ReadAloud task.


OK, but just to clarify… Tasker can clear all notifications from SmartThings if you program it that way.

(My Registered trademark symbol always triggers Tasker, and the notifications get cleared 7 seconds later. Your programming might be different, but if you followed along in my tutorial, yours may be doing the same thing)

I have never seen messages come in without a notification in the tray except for three possibilities.
(1) Not being logged into the ST app
(2) The phone has notifications blocked for that app
(3) Tasker has cleared the notification before I noticed it

Anything beyond that and I would need to see full logs for a notification test


I did a factory reset and I have notifications back. I understand what you were saying but 1. I was logged in, 2. Not blocked on my apps (that i needed) 3. I turned off the tasker speaks task so there was nothing in tasker clearing notifications. I appreciate your help.


And…they are gone again. So odd. Nothing changed to my knowledge and it is only with ST.