[Install Instructions] webCoRE Presence Sensor on your iPhone (beta)


the outer circle needs to be as large as possible. The minimum possible size is 250m. Meters, not feet. That’s over 750ft.


No, Joel that’s how many feet above sea level you are. If you look closely you will see there is a background picture of mountains behind that 175 feet figure.


OK I bad, I will test tomorrow. i set up a Piston, if the Piston works it will send a push as soon as I leave and as soon as I return.


I’m cannot figure out how to send you a pm to request the TestFlight access


You’re a brand new user.
Trust level 0. You have to graduate to TL1 to initiate a PM.
Spend an hour tooling around reading threads, reply a few times and like a few posts. System will unlock TL1 pretty quickly.

Make your request here. Then PM @ady624 when you reach TL1


Ok thank you, I just want to try the webcore presence app LoL. Didnt want to spend all night getting there. I will cruise around a little and hope it’s quick. Thank you again


It’s fast. I honk one of the system requirements is an hour spent total on the forum. That’s the hardest part to get TL1


Ok :crossed_fingers:t2:



Sorry if this topic is covered. Tried to search, got nothing.

I have followed steps in instructions. In step 6. “…The green button should now disappear from the list. When it does, click Apply to close that window.” Mine does not. i’ve tried 6-8 times with different names. The green buttons remain and no device in ST app…



Make sure the DTH is correctly installed AND published. Then kill the app and try again


No, still same result. Went trough all steps again to check if I’ve missed something. DTH is installed from GitHub and published…


Any errors in the IDE Live Logging when you press the Save button after entering a name for the device?


47949a84-bbaa-4305-8a34-a383387a4d95 14:40:31: debug getChildDevices(false), children=0
47949a84-bbaa-4305-8a34-a383387a4d95 14:40:31: error Please install the webCoRE Storage SmartApp for better performance
47949a84-bbaa-4305-8a34-a383387a4d95 14:40:28: debug getChildDevices(false), children=0
47949a84-bbaa-4305-8a34-a383387a4d95 14:40:28: error Please install the webCoRE Storage SmartApp for better performance
86f95be0-2743-42c9-803c-faebc9aa3ba0 14:40:22: trace Last code check was done 42.075 seconds ago
86f95be0-2743-42c9-803c-faebc9aa3ba0 14:40:22: trace Heartbeat monitor called
47949a84-bbaa-4305-8a34-a383387a4d95 14:40:21: debug getChildDevices(false), children=0
47949a84-bbaa-4305-8a34-a383387a4d95 14:40:21: error Please install the webCoRE Storage SmartApp for better performance
47949a84-bbaa-4305-8a34-a383387a4d95 14:40:17: debug getChildDevices(false), children=0
47949a84-bbaa-4305-8a34-a383387a4d95 14:40:17: error Please install the webCoRE Storage SmartApp for better performance
47949a84-bbaa-4305-8a34-a383387a4d95 14:40:17: error physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘webCoRE Beta Presence Sensor’ in namespace ‘ady624’ not found. @ line 1281
6263ada4-0282-45d3-8948-68cc4ddcf6c3 14:40:17: debug Not parsing XML message:
<s:Envelope xmlns:s=“http://schemas.xmlsoap.org/soap/envelope/” s:encodingStyle=“http://schemas.xmlsoap.org/soap/encoding/”>
<u:GetVolumeResponse xmlns:u=“urn:schemas-upnp-org:service:RenderingControl:1”>


Did you change the handle() of webCoRE’s app from webCoRE to webCoRE Beta? Can you please update webCoRE to the latest version? Also install the Storage and the Piston apps. And publish.


All is working now. My own misstake, ofcorse. -.-
I got some help and I was told to rename the smartapp to WebCore Beta to tell them apart. I misunderstood him.

Thank you for all help! :slight_smile:


Working well, now. I left the house with the standard Geo fence settings and I received the Away message at .3 miles from home. I then changed it to a smaller Geo Fence and I received the message 75 feet from home. So I guess with the delay it is around 200 feet is the edge. Still very good. Below is a test Piston, does it look correct? Thanks


Let’s see if a non-expert can come up with what the experts will suggest:

I would change it to be

If Presence Sensor 1 presence changes
  If Presence Sensor 1 presence is present

Only want to trigger once then check the condition

That is what I would do in my native development…


Thanks, I am not sure which way to go. The reason I wrote it that way is the experts showed me similar. But I really want to get the critic from the experts. That way I get rid of my bad habits. Intend to do thing in an irregular manner.


Here is one from the master himself.

This will only notify on current place you arrive at or have left from. Not arriving at or leaving from. But you will be notified when you actually arrive and when you have actually left.


Thanks, that is all I want to do is use it for presence at my primary location.