Is the WebCore interface down?


Is webcore down? I can’t access it from the hubitat hub or just going to
I get this error (I have logged out and tried from multiple devices):


I am able to access WC from within the Apps page of Hubitat. I only have a test piston in there tho.


I gave up on webcore on Hubitat a few weeks back after the release of 3.10d. I could never get the dashboard to load after that. Even uninstalling/reinstalling failed to resolve my dashboard issues and I could not locate an older version to install. That and the fact, piston schedules were haphazard on Hubitat. One day it would run but the next day it might not.


Crap! I have so many rules on webCore and now can’t see them to even recreate them…what a mess.


What I have found on HE:

  • if your HE hub crashes/power fails and reboots, you are likely going to need to do a “nice reboot” of the HE hub after it comes back up (nice means HE console -> Settings - “reboot” or equivalent)

    • what I have found is after an “unexpected” restart, that everything does not start properly in HE
  • If you still have a problem you can go into webcore (HE console -> Apps -> webcore) and hit done (this causes this webcore instance to re-register with the webcore servers).

  • I have on occasion found I need to clear caches in your browser (hard clear)

The above get things working if you had a problem (unless webcore servers have a certificate issue)


Thank you @E_Sch!! I had done most of that but a combination of rebooting the hub and hitting “Done” on webcore seems to have fixed it!


Well, I spoke too soon - I can now get webCore to load, but when I click a piston to modify, it just spins and never comes up.


It’s all good! I have uninstalled it at this point and stopped using it. Everything I need is on ST and working well there.

Sorry, just not a fan of Hubitat.


Yes it’s very frustrating…I can now see my pistons in a list but not the code to edit them.


How do I find an older version of webCore to load? I feel like the last version was much more stable.


Actually I just looked at logs - any idea what this means or how to fix it?

app:972019-07-24 04:19:23.143 pm debugDashboard: get piston :605be4b78449f6723e47ea54e8451bc7: needs new db current: v0.3.10d.20190627 in server undefined


This is in the HE instructions webpage.

When you / your browser logs in (or after a webcore groovy code update), on first piston load the webcore servers require more data to be loaded into the webcore server.

After a new browser login, I first open a small existing piston from the dashboard (any one), so that the data can be uploaded. (small means not many lines of code)

The core issue is HE has a limit of 128KB - headers as maximum single http request update/response.

So if you open a large piston first, that along with the 1 time data upload can exceed the 128KB. Using a small piston won’t exceed, and the server won’t ask for the data upload again until a re-login (or next webcore code update).

This data upload is “for the webcore IDE”…

webCore stopped working for me

Not sure I understand - this happens on all of my pistons, large and small…and doesnt’ matter if I open from hubitat or launch the webcore dashboard first.


Actually I got it…none of my pistons worked, but trying to create a blank new piston got the db version to update…thanks @E_Sch!