Launch App By Voice on Fire Tablet 8 HD Plus (10th Additon)


1) Give a description of the problem
Trying to Launch an App by Voice on my Fire Tablet 8 HD Plus (10th Addition).

I can get it to work on my iPhone with a Piston I created in WebCore that sends a PUSH notification to STs, but cannot get my ST PUSH Notifications working on my Fire Tablet 8 HD Plus.

2) What is the expected behaviour?
How can I Launch Apps by Voice on my Fire Tablet 10 HD (10th Addition)? Seems like I need to create a Piston in WebCore that sends a PUSH notification to STs, but cannot get ST PUSH Notifications working on my Fire Tablet?

Is there another way to customize Voice Commands on my Fire Tablet to execute specific tasks?

3) What is happening/not happening?
Push notifications for STs is not working on my fire Tablet, but is for my iPhone.


All of the tricks I use require first getting ST’s notifications on the device.
Have you tried the SmartThings Classic app, or are you using the newer app?

Also, did you grab the app from Amazon, or from Google Play?
(they are different versions)


Thanks a lot for your response.

Tried this with the Classic App and New Smartthings App on my Fire 8 Plus Tablet. Also, toggled the notifications inside the app and on my tablet on and off and back on + redownloaded both the Apps as well from the Google Play Store.

Additionally, tried deleting the Google Play SDK packs and redownloading the Google play SDKs for my tablet.


Emailed Smartthings, but haven’t heard back.


And you verified that notifications for that app did not somehow get turned off in settings?


If memory serves me right, out of these four apps:

At least one of them require playing around with the “Store in message” option…



Thanks @webCoRE.

My pistons have PUSH Notifications as “Value: True”.

Maybe I am missing something I didn’t know I could download the Smartthings apps on Amazon (#1 and #2 on your list)?

When I search in Amazon’s App Store on my Fire tablet 8 Plus I am not seeing it.

Although, I would assume it wouldn’t work even if I did download them since it’s not from the Google Play Store.

Let me know what you think/am I not understanding something correctly?

Thanks again a lot! Been spending a lot of time on this.

Screenshot showing no Smartthings App in Amazon:


The frustrating part is, a Fire tablet is not running pure Android, but a modified version of it. Likewise, in the Amazon app store, the apps there are also modified from the originals…

If Amazon no longer has SmartThings in their app store, that is a bit of a red flag to me.

The other thought I have is, in the ST app, are you 100% positive that you have logged in correctly to the same account as your webCoRE?