LIFX Integration Issues - Missing ST Flexibility



Recently moved to Hubitat from ST and it seems WebCore doesn’t handle LIFX bulbs the same via each platform.

With ST, I was able to select individual bulbs (or groups) under “selection” when using a LIFX action. Now I only find scenes here.

Is there something I’m missing? I was under the impression LIFX bulbs should be used with WebCore’s LIFX specific actions (LIFX breathe, LIFX state, etc.)



Here’s a screenshot showing my options under “Selector” for “LIFX - Breathe”

Previously I could either select individual bulbs or the groups I had within my LIFX app.

Edit: Here’s what it looked like when I was using SmartThings


Well I fixed it, however I’m not exactly sure what did it.

If anyone stumbles across this issue in the future, there’s a couple things I did…

  1. Replaced WebCore Settings LIFX API Code with the one I was using for my SmartThings WebCore setup.
  2. Installed the “enhanced” LIFX device drivers.
  3. Re-Installed all my LIFX bulbs using the built-in Hubitat integration.
  4. Upgraded each bulb’s device type to use one of the corresponding “enhanced” drivers.
  5. Added all the new bulbs to every category possible within the WebCore App “Available Devices” section.

I now have back the ability to select by bulb, group, location, and scene just like I originally could with ST + WebCore.


I’m not sure if it’s related, but I had an issue with some devices (not lifx) when I migrated them from ST. Not all the capabilities of the device would show up under HE devices. Deleting the device & re-adding resolved the issue.