Making voice announcements & controlling Amazon Alexa Echo


thanks WCmore:)))

“Alexa yes” sound very good, i love it.
pls let me know when ever it’s ready… can’t wait to add this to my house.


I’ve tried this on and off several times and can never get it to work with my GH. But when I saw your other post yesterday WebCoRE asks a question, my voice response determines the action I wanted to try again. The problem I’m having is that I am receiving the notification on my ST and it’s not being passed to my GH. I checked which apps I marked per the instructions above and found that I have several ST listed under apps. See screen shot. Any advice?


I am a bit confused by your question. If the screenshot is from Tasker, and you are trying to make voice announcements, then checking all of them would be my choice. (although I wonder why it shows so many SmartThings app installed)

Can you send a screenshot from your Tasker Profile (left side) that says “AutoNotification Intercept Event Behavior”?

Mine looks like this:


It is also important to clarify that you need some kind of speaker connected to the Android. (via Bluetooth or 3.5mm wire) You can test this portion by picking up the Android, and doing anything that makes sound. (game, MP3, podcast etc) Does the sound come out of your large speaker?

For this method to work, every single sound your Android makes should be piped directly to your external speaker.


Yes, I’ve checked all the Smartthings listed and yes a Bluetooth speaker is attached. I even hear the ST notification from the piston I’m trying to run. It seems the notification isn’t being intercepted


With AutoNotification, reduce the specifics as much as possible on the intercepts. The more specifics you include, the more likely something will be missed. So start with:
Event behavior: true
Notification type: all (whatever that is, been many months since I did this)
Persistency type: both
Notification app: Smartthings
Notification title: blank
Notification text: blank
Package name: blank

Only get specific later on, as needed. For now you want it to be as open as possible.


Glen makes a good point. I suspect if you have 5 versions of SmartThings installed, that the line:
Package Name:
is the line that needs editing to point towards the correct app (or left blank).

Side Note:
Do not drop the symbol next to Notification Text! That is required to filter out other notifications

Also, Notification Type must remain “Only Created Notifications” or each trigger will repeat twice.


I just noticed you need a capital “T” for SmartThings in two sections:

This is likely the culprit.


I’ll give these things a try when I get back into town tonight! Stay tuned…


Update - I hear the ST notification tone but it isn’t speaking. Thoughts?


Sorry to ask again, but can you send a screenshot from your latest Tasker Profile (left side) that says “AutoNotification Intercept Event Behavior”?

An easy way to test the voice is
If you write a one line piston:
Send PUSH notification "® This is only a test"
and then test that piston to send the notification…

The tiny symbol at the beginning of the PUSH notification is the registered symbol.
An R with a circle around it. ®

Pro Tip

I actually save this test piston permanently.


It’s perfect for a single line copy/paste into other pistons.
(which saves me the time of using ‘Character Map’ to copy that symbol each time I want something spoken)


Tested using simple piston. Received “this is only a test” notification ding and text on phone, heard notification tone on connected Bluetooth speaker… But no words


Just to clarify, was the notification on your phone

this is only a test
® this is only a test


If the symbol didn’t make it thru, Tasker won’t do anything with it.

Also, just to rule it out, can you uncheck everything under “Notification Apps”. (plural) and delete the info stored under “Package Name:”. Those are the two areas that would conflict if you have 5 versions of SmartThings installed.


Notification was on my phone (words & tone) with ®. Tone only on speaker.
I actually switched to another old Android with only one ST listed under apps.


I am tied up the next 36 hours, but afterwards, I will troubleshoot with you in a private message, and post the results back here afterwards.


Oh. This is the first time you said that Tasker did read it outloud.

In that case, it all falls back on how your phone is connected to the external speaker. A requirement for this to work is every single sound your phone makes should be directly piped to the external speaker. I use 3.5mm jack or Bluetooth connection to achieve this.


Sorry - written “words” - nothing spoken at phone or speaker.


Ahh ok. I sent you a private message



Sorry if my step-by-step guide is fairly complex in my first post.
If you tell me what area got you hung up, I will edit that post for clarity.



For some reason I am getting hung up on “Step 6 Detailed Instructions:” and I am getting this error:


These setting are not valid. If you exit now settings will be lost.

Are you sure you want to exit?

I have tried following Step 6 multiple times.


I would need to see a screenshot of your Profile: “AutoNotification Intercept Event Behavior”

Mine looks like this: