Making voice announcements & controlling Amazon Alexa Echo


#161

OK cool…

Can you import and test the following?

pic


This will give us a quick and easy way to test.

Once you press Test, keep your eyes on the Android… Especially the notification tray…

about a half sec after it comes in, Tasker should read outloud the message…
(and if you followed all of my advice above, the notification will clear itself about 7 sec later)

Can you explain in detail what actually happens for you?


#162

Sure, I didn’t think to just use the test button, so I had it set up to send a push notification when I pressed one of my Samsung buttons. When I do so, I get the notification pretty much instantly, but it just stays there and nothing happens. The notification doesn’t get cleared or anything.


#163

OK cool…

Can you send me a screenshot of your Tasker logic?

It should look something this:


#164

Sure! Here it is. Do you need more specific screenshots of the tasks themselves?


#165

I was hoping it was obvious from the screenshot, but from a distance, it looks good.

To look a bit closer, would you be willing to share the contents of line 1 and 3 here?


#166

Sure! Here they are:


#167

Those two look spot on…

A couple of questions to try to narrow it down:

(1) Does Tasker clear the notification 10 seconds after it comes in?
(or does it linger indefinitely?)

(2) On line 3, next to “Engine:Voice”… did you type that out, or did you click on the magnifying glass to choose from a list? (every device has different voices to choose from, so typing what I typed will likely not work)


I have more thoughts, but let’s start with these…


#168
  1. It lingers indefinitely unfortunately. I have to swipe it away myself if I want it to go away.
  2. I have tried both. I manually typed it out originally but have since searched through the options to find what was in your post and it matched anyway.

#169

OK, this indicates that the trigger is not registering for some reason…

Can you please share a screenshot of the trigger?
(from the Profile tab, touch on “AutoNotification Intercept” found underneath the title)

Mine looks like this:

a_ProfileEvent_30

… but it may look a tad different pointing to the new ST app.
(IE, the last line may be: com.samsung.android.oneconnect)


Note: Samsung has blocked me from the new app (so I am unable to confirm), but it is very possible that the name may be showing up a bit different than the Classic app.

Basically, you should double check that:

  • App & Apps should both reference the new ST app… Whatever it is called
  • The Title exactly matches the notification Title from my test piston… (cAse seNsiTive)
  • The Package Name matches the correct app (some delete this line, but I like to use it)

#170

Okay, here is a screenshot for you:

I’ll look into the names again and the package. What is the easiest way on Android 8 to figure out the package name of an app?


#171

Your screenshot looks amazingly accurate… (the new app must use a different name)

  • I use a normal web browser…
  • Go to Google Play in that browser
  • Search for the app in question, and click on it to see the full page
  • Verify that the icon looks familiar, and this is the exact app you have installed
  • Copy the end of the URL
  • Paste it back in Tasker

pic

Note: On some versions of Androids, you can check “App info” to find that info, but not always.


#172

Ahh! It works now! I’m not sure which one fixed it (probably both) but I changed the package name to that one you have listed and I also had to change the title name to “My home”, as that is the title of the notifications in the new app.

It does seem sort of fast for a spoken notification though. Any way to make it more human or slower?

Thanks so much for helping me!


#173

Glad we got it working! I will update my first post with our findings…


Commas and periods add a bit of delay between phrases…
(but unfortunately, “dot dot dot” does not triple that delay)

Perhaps a better answer would be: You can edit the “Task” on line 3 (the Say command).
Here, you can play with Pitch & Speed… as well as choose other voices, if you like.

Once you change something, back up multiple times to the desktop (to save Tasker)… Then you can press the Test button in my sample piston above to hear the latest tweaks.

It is also possible to download new voices to your Android, but oftentimes, there are some decent ones already pre-installed on the device. (my favs are: eng-aus, eng-gbr & eng-usa, but feel free to experiment)


Edit:

Before I update my original post, can you share a new Profile pic showing the working trigger?
(the latest “AutoNotification Intercept”)

Also, is “My home” your choice of words, or is that the default Title that everyone will see on their devices? (I guess anyone with the new app can answer this last question)


#174

Sure! Here’s the updated profile:

I believe that the “My home” is just the name of the location in the new ST app that I’m controlling. So I think the default is “My home”, but I suppose someone could have several of those or use a different name.


#175

Thanks @andrew9mb!

I just edited my original post to account for the new app.

Basically, in the Profile trigger, I changed:

  • Notification Title: My home
  • Package Name: com.samsung.android.oneconnect

In the Task I changed:

  • Line 1 = Title: My home
  • Line 5 = Notification Title: My home

For reference, (or for those still using SmartThings Classic), previously it was:

  • Notification Title: SmartThings
  • Package Name: com.smartthings.android

#176

Has anyone got this to work on a Fire tablet?
I installed New smartthings app on my Fire 8 but I dont get ANY notifications, even before adding Tasker.
I double checked notifications are enabled, but the simple test piston listed only notifies on my iPhone


#177

I gave up on FIRE Tablets. Same issues being reported in the Smarthings Community pages

I picked up a ONN 8" tab from Wal-Mart for 13.00. Been playing with it. Couldn’t get it to work until I tried to leave the Say command at the default (Engine:Voice= default:default & Stream = Media)

This is way better than EchoSpeaks and or Voice Monkey that got shut down.