Missing a few thermostat modes like dry mode and fan only


Im trying to setup a few thermostat pistons, but for some reason I cant choose in thermostat mode either dry or fan only mode? Is this because those are not added to webcore? Or am I doing something wrong?
If I push the dry mode and fan only mode buttons on the sensibo device in things, it works great.
And a few other smart apps can also be used, but with webCore when I got to set thermostat mode, I can only choose on, off, heat , cool, & auto, please let me know.

PS: bigup for this new community, looks nice


@ady624 any chance you can share some knowledge? if this is possible to make happened in webCoRE ? I can easily click directly on the various settings in things / device (auto, on / off, cool, heat, dry , fan only, but in webCoRE I can’t find fan only, and dry thermostat modes. Is it limitation of device handler or is it something that is not added to webCoRE? thank you in advance…


webCoRE is largely device agnostic and goes by capabilities as they are described by ST. See here what ST has to say about thermostat modes: http://docs.smartthings.com/en/latest/capabilities-reference.html#thermostat-mode

Check if your device exposes any commands that you could use instead of setting the thermostat mode. Check to see if there’s any command dry() or fanOnly() etc. in the Task list for the thermostat - they would be under Custom.


If I understand you correctly its something that needs to be added to device handler for the capability to appear in webCoRE ?
Do you know what to look for in device handler and what to add?
Should it be possible to make it work like this? cause I have a few days left to test this before I return the thermostat device , and If I can’t program the fan and dry mode in webCoRE I would need to get ahold of another thermostat.


Apologies for picking up this thread several years later, but I couldn’t find anything else relevant. The list of thermostat modes which appears to be known to WebCore is out-of-date, as the newer smartthings capability has a much wider range of modes available. Also I note that WebCore appears to see ‘supportedThermostatModes’ correctly, but gives a different list when you try to use one of these modes in a piston. Have I missed something?