National Weather Service API request - forecast problem


1) Give a description of the problem

I am pulling the forecast data from the National Weather Service at,44/forecast
2) What is the expected behaviour?

Current weather
3) What is happening/not happening?

Period [0] should be the most recent forecast. But my $response is giving me old data from 2 days ago.

Is my $response retaining old data for some reason?

**4) Post a Green Snapshot of the piston![image|45x37]



I haven’t done that sort of thing for a while. Is the webCoRE syntax really periods.[0] and not the Groovy style periods[0]?


It works! :thinking: Just old data for some reason.


Do you get old data if using a browser?


No. Up to date if using a browser.


Hmm that is strange indeed.


It’s like $response is caching data. Is that possible?


I was thinkin that but not even sure how to troubleshoot something like that lol. I can’t test it since I will get different data from yours.


Using the link in the OP should give you the same data I am getting. But if you use a browser, it will be up to date.


Oh oh, have you tried clearing webcore cache in HE app?


Yep. No dice.


Darnit, I tried lol. Will give it a shot later when I get home.


What is REALLY strange is SOMETIMES it works correctly without any modification to the piston.