Piston exection delayed


I have a piston that has been running for months with no problems, however in the past week or so, there seems to be a large delay in parts of its execution. I’ve pasted the relevant section and a log as the main piston is rather large. (I should/could probably split into separate pistons, it was one of my first and has grown over time)

The issue is in a simple section that turns lights on an hour before sunset. Two of the lights are in the same room, and used to come on together. Now there is a long delay as shown in the log.

I suspect it may have something to do with the delayed light being a fibaro dimmer and the DH runs in the cloud. But I don’t know why this has suddenly started happening. Also, other pistons that interact with the same device work fine. e.g I have a goodnight piston which always turns the light off instantly.

Also, maybe related, A piston that turns on another fibaro sometimes exhibits a similar delay, but not always.

27/06/2020, 20:37:59 +181ms
+0ms ╔Received event [Home].time = 1593286680000 with a delay of -819ms
+148ms ║RunTime Analysis CS > 32ms > PS > 52ms > PE > 64ms > CE
+152ms ║Runtime (59617 bytes) successfully initialized in 52ms (v0.3.110.20191009) (151ms)
+153ms ║╔Execution stage started
+279ms ║║Cancelling statement #61’s schedules…
+304ms ║║Executed physical command [Landing lamp].setLevel([100]) (21ms)
+306ms ║║Executed [Landing lamp].setLevel (23ms)
+309ms ║║Cancelling statement #63’s schedules…
+335ms ║║Executed physical command [Hall lamp].setLevel([50]) (20ms)
+336ms ║║Executed [Hall lamp].setLevel (22ms)
+338ms ║║Cancelling statement #76’s schedules…
+360ms ║║Executed physical command [Lounge Lamp].on() (19ms)
+361ms ║║Executed [Lounge Lamp].on (21ms)
+371ms ║║Calculating (integer) 2 * (integer) 60 >> (integer) 120
+373ms ║║Calculating (integer) 120 * (integer) 60 >> (integer) 7200
+376ms ║║Calculating (integer) 7200 * (integer) 1000 >> (integer) 7200000
+380ms ║║Calculating (datetime) 1593290102509 + (integer) 7200000 >> (datetime) 1593297302509
+384ms ║║Comparison (datetime) 1593297302509 is_greater_than (datetime) 1593290279563 = true (2ms)
+386ms ║║Condition #81 evaluated true (21ms)
+387ms ║║Condition group #80 evaluated true (state did not change) (23ms)
+389ms ║║Cancelling statement #82’s schedules…
+4785ms ║║Executed physical command [Lounge Lights].on() (4392ms)
+4786ms ║║Executed [Lounge Lights].on (4394ms)
+4821ms ║║Executed physical command [Lounge Lights].setLevel([100]) (32ms)
+4822ms ║║Executed [Lounge Lights].setLevel (33ms)
+4826ms ║╚Execution stage complete. (4673ms)
+4828ms ║Setting up scheduled job for Sat, Jun 27 2020 @ 9:38:00 PM BST (in 3595.991s), with 1 more job pending
+4837ms ╚Event processed successfully (4836ms)


Not sure why the > 4 second delay. Hmmm, just off the top of my head…no coffee yet… have you tried asynchronous execution?


I’ve not really tried anything. I’ve not made any changes for some weeks to anything. The only thing I had thought of is that currently the ‘landing lamp’ smart plug is not plugged in. I had wondered if that was causing a timeout, but from the log, that doesn’t seem to be the case.

I’m wondering about network congestion somewhere, I’ve noticed some latency on web pages loading on my laptop, but had put that down to the win 10 2004 update.