Piston pause and execute not working


1) Give a description of the problem
Did a pause_piston and it does not pause on execute other pistons.

2) What is the expected behaviour?
When switch138 is not present -> execute two pistons
When switch138 is present -> pause pistons

3) What is happening/not happening?
Nothing. I can see that piston did run when presence changed but those two pistons stay paused.

**4) Post a Green Snapshot of the piston![image|45x37]image

5) Attach logs after turning logging level to Full
I added virtual presence sensor (presence_vswitch) to test how piston works. Here’s results (pistons did not execute or pause)

11.8.2021 klo 13.04.58 +196ms
+21ms ╔Received event [Presence_vswitch].presence = not present with a delay of 28ms, canQueue: true, calledMyself: false
+26ms ║RunTime initialize > 24 LockT > 1ms > rtDT > 2ms > pistonT > 1ms (first state access 21 22 2)
+32ms ║Runtime (6543 bytes) successfully initialized in 2ms (v0.3.113.20210703_HE)
+33ms ║╔Execution stage started
+42ms ║║Comparison (enum) not present changes_to (string) not present = true (1ms)
+44ms ║║Cancelling condition #2’s schedules…
+47ms ║║Condition #2 evaluated true (10ms)
+49ms ║║Cancelling condition #1’s schedules…
+51ms ║║Condition group #1 evaluated true (state changed) (14ms)
+52ms ║║Cancelling statement #3’s schedules…
+94ms ║║Executed virtual command executePiston (32ms)
+103ms ║║Executed virtual command executePiston (2ms)
+113ms ║║Comparison (enum) not present changes_to (string) present = false (1ms)
+116ms ║║Cancelling condition #7’s schedules…
+117ms ║║Condition #7 evaluated false (9ms)
+119ms ║║Cancelling condition #6’s schedules…
+121ms ║║Condition group #6 evaluated false (state changed) (14ms)
+126ms ║╚Execution stage complete. (92ms)
+130ms ╚Event processed successfully (110ms)

Is there something basic I just do not understand when executing or pausing pistons?


Hi @Jani. As you are that stupid as it seems, try changing “execute” to “resume”. Maybe that will help you idiot.


Hi, thanks @Jani. Great that I found the issue and helped myself so quickly.


You should flag yourself.