Piston will not work


Trying to use the piston to turn off the monitor when there is no motion for 30 min
In the logs, it looks like it cancels the piston, not sure why


Instead of “If comp_motion is false”, trying changing it to “If comp_motion CHANGES TO false”


It appears the active trigger is cancelling the inactive timer prior to the 30 minute mark.

9:32 inactive
9:54 active (22 min)

The time was cut-off on the most recent log entry but i imagine that was also before the 30 minutes.

As an aside, why not just simply the piston and get rid of the boolean involvement all together. All you really need is the motion is now and stays active with the switch off in that block.


Changed the piston to this but still will not turn off monitor
logs look at 10:44:53 sets up a schedule for 10:52:53 and at that time says it was processed successfully but it didn’t turn off the switch

Wait a min I think my hub is frozwn nothing will turn on or off. Rebooting


Nope still same thing… I know the switch works I can turn it on and off through Hubitat.
Says its setting up a schedule and when the time comes says Event processed successfully


Have you clicked “test” this seems to activate the “is now and stays”. I have a very similar piston to this I’m testing and I’m not finding “is now and stays” too reliable. I seem to have to click test quit often to get it working again.

I’m not sure for your case why you dont just use a wait. If there is motion again (active or inactive) the wait will be cancelled and then started again as the piston runs top to bottom.

This is the default behaviour, but can be changed by the task cancellation policy for other use cases. It’s well worth reading upon this


I would be sure your webCoRE is up to date
ie HPM repair on webcore.

Are you using built-in or user install on HE?

I would then show full logging for the piston with problems.