playText / Speak text commands not showing volume setting in the IDE


Using webCore with EchoSpeaks on Hubitat…
There are three commands for speaking:

  • playText
  • playTextAndRestore
  • playTextAndResume

all three commands accept an optional Volume parameter, but the IDE does not display the volume setting. I believe this is just a minor typo omission in the webcore.groovy code. I have made these changes on my local copy and appears to work.

Can one of the webCore developers verify these edits, and if correct push them to the master branch on github

Existing webcore.groovy code:

Edited to display optional volume parameter {1} (also add missing comma at end of playText definition)


I’ll look into this.