Problem to install webCore on ST APP (perfect with ST Classic APP)


Im a newbie which started yesterday with webCore.
After watching Robin video, regarding the webCore, I attempted and install like the video.

Perfect with APP Smarthings Classic, like the next picture.


But the problem come with Smarthing APP. Imposible to install webCore. I have the next error.

Sorry for Spanish. “Error with network or server, Please try again later” And cant Install webCore.

Any help?



I can install on my mobile phone with 4G Data, but when I change to WIFI and try to open the webcore on Smartthings APP, same error.


Are you actually trying to install webCoRE using the ‘new’ app? It should already be there if you’ve installed it using the Classic app. Or are you trying to run the already installed app? Either way it should work.

The 4G v wi-fi issue has come up many times before. I can’t recall if it has ever been explained or an answer found.

The ‘network or server error’ messages appear rather too often in the app, where more precise error messages would give more confidence. They often go away by themselves but there is just no way of knowing what is going wrong.


I can install webCoRE usind the Classic app (via WIFI or 4G without any issue) but If i try to install using the “new app” via WIFI, cant install ( network or server error)

At final I can install using the new app via 4G, all perfect. But If I try to connect to my webCoRE using the new app via WIFI appear the same error (network or server error).

4G no problems.


Another question.

Can I remove Home \ webCoRE.


I don’t understand why two appear now.


Some SmartApps only let you have one instance installed. WebCoRE lets you install it multiple times. So if you installed webCoRE once using the Classic app, and again using the new app, then yes you will have two instances of it. You should also see both instances in each app. If you don’t want one of them, just delete it using one of the apps.


Do you have any type of adware blocking on your wifi network such as AdGuard? They can cause errors you have described.


Yep! Raspberry with PiHole.




For future reference, can you tell us what site(s) you whitelisted to get webCoRE working?


I saw where another user whitelisted and


Thank you… I have been looking for a good whole house ad-blocker…