Rain Sensor False alarm


#1

I am trying to create a piston that will notify me when a leak sensor stays dry. I’m using it in a greenhouse to determine if it stops raining.
The problem has been with the sensor changing back and forth for no apparent reason. I’m looking to eliminate the false alarms by creating some delays. So far I’ve had no luck. Do you think this one would eliminate the false alarms by watching for it to turn wet for a couple of minutes and then back to dry for a couple of minutes. Otherwise if those conditions aren’t met it does not send the text message which is what I’m using right now just to see if this works.


#2

I’m not sure if the wet sensor would dry in 2-3 minutes.
I have wet sensors but I use them for water leaks.

What you can do is, check it maybe 30 minutes after it’s gotten wet.

IF water sensor changes to WET
With _(TCP set to never)_
Location 
Wait 30 minutes
       IF water sensor IS WET _(meaning still wet, so raining)_
       Then 
       Do this do that

#3

What is TCP set to never?


#4

This post of mine explains it…


#5

For some reason I don’t have a “with” to change the TCP to never. What am I missing, other than “with”? :hushed:


#6

It is probably above the “Location” canister… (seen while in edit mode)

pic


#7

Nope. I have checked on every box that shows I guess what would be called all the options and “with” does not show up. Is there another way to get to that TCP setting? setting? It does not allow for an anonymized snapshot in edit mode to send you.


#8

While editing, the WITH line should be after the THEN, and before the SEND SMS.

pic


Note, I am using a PC to edit my pistons.