Recover deleted pistons


1) Give a description of the problem
I had issues recently getting random characters for my device names so tried lots of things from my search here in the forum. Also, got can’t load devices message all the time on chrome/edge/etc browser. Somehow I ended up with a duplicate webCore Piston smartapp in my IDE. I was not smart enough to backup all my pistons before messing around today. I deleted the webCore/Dashboard/Storage smartapps in my IDE to see if I can remove that duplicate entry for webCore Piston.

2) What is the expected behaviour?
Is there a way to recover the pistons from the accidentally uninstalled webCore instance?

3) What is happening/not happening?
I can’t access any of my pistons as my new installation shows no pistons. I can’t remove that 2nd instance of webCore Piston smartapp as it says sorry, you cannot install a piston directly from the marketplace if I click on it my smartapps in automation on phone nor delete it from IDE with “This SmartApp can’t be deleted at this time because it is installed by one or more users”

**4) Post a Green Snapshot of the piston![image|45x37]
Didn’t have a backup so don’t know their backup codes to restore from.

5) Attach logs after turning logging level to Full


If you have just one backup code, perhaps from a piston snapshot posted somewhere, then Adrian (@ady624) may be able to identify your WC instance on the server and provide you with a list of all the other backup codes. He needs at least one identifier as all he can see is anonymous backup codes grouped under anonymous instances.

You would need to send him a PM on here and perhaps on ST, but he’s not very active these days.

Failing the above, you have no route to recovery I’m afraid.


Thanks for the reply. Unfortunately, I didn’t write down any of the backup codes I had done on a few of them over the years. I’ll perform one last search on my PC before resorting to manually recreating the pistons one by one.

On a positive note, the new WC instance I installed lists all the devices properly instead of a long string of random characters AND I no longer get the can’t load devices message.


YIKES! I bet I have over 100 backups…


Yep, a lesson to be learned here for everyone.

That said, I wouldn’t waste too much time recreating all your pistons, as the future of webCoRE on ST is short / unknown, what with ST depreciating groovy any all… I would suggest that this may be a good time for you to jump ship and move over to Hubitat :wink:


Search came up empty as I had purged all of the old notes I had for my pistons. I won’t be recreating too many pistons based on your note regarding future of WC. On the bright side, there won’t be much to migration to a new platform due to my careless mistake.


Tag @ipaterson also, he might have another trick to help you out.


It’s fairly simple to migrate pistons to Hubitat anyway, you can use ST backup codes / files to restore in Hubitat.

I recently moved 213 devices from ST to Hubitat, I had it all done in less than a day.


That’s good to know that it’s not going to be a chore to migrate. Cheers.


Update, I found a way to retrieve the backup codes!!!

I was poking around my IDE and happened to review the duplicate webCore Piston instance I couldn’t delete in my IDE. Within that webCore smartapp Parent, I noticed there were “Installed Smart App Children” listed with links to all the Pistons I had created. That gets me most of my pistons back because the links pull up Settings where it housed the text value for the backup codes. Woohoo, that saved me the majority of the recreation work. Only issue was I couldn’t get the links to resolve for any of my paused Pistons but that is fine. I’m happy to get back what I got so hope this helps others if they get in same situation.


I thought you said you deleted those lol… nice stuff.


Somehow I ended up with two webCore Piston child smartapps in my IDE. I tried to delete all WC smartapps but IDE only allowed me to delete the parent WC smartapp and 3 child smartapps but not the duplicate webCore Piston child smartapp. The undeletable WC child smartapp was what saved me and allowed me to recover the backup codes within it’s settings. I then reinstalled WC and still have an extra WC Piston smartapp that I can’t delete as seen in screenshot below. I’ll just leave it since my restored pistons work fine with the duplicate smartapps. I lucked out this time.