[RELEASE] Using Twilio to Send SMS



tested 2jg7b with my devices…i verified my SMS master is working with another piston. Using this piston the logs show me opening a door…turning on sw1 but when both conditions are true…i do not get an alarm. also the motion sensor does not come up on the piston log, but i see it change to motion on my ST app.


I assume ‘switch 4’ is your override switch? if so turn off event subscription for lines 23 and 31.

What is ‘sw1’, I can’t see that in your piston.

Please also post a image of your master piston (with URL and codes redacted).


it shows as switch 4…actually sw1


Why would opening a door turn on a switch?



i will replace SW-1 with a switch i created to be activated when ST is armed and in alarm state. that is why i put the “and”


Using this piston the logs show me opening a door…turning on sw1 but when both should have written when i turn on sw1…


Your Trigger pistion is calling a master piston called ‘Master Alarms to SMS’:


But your master piston is called ‘Master Alarms to SMS xxxdd’

In addition to the above, turn off event subscription to sw1, that’s not the desired trigger, motion or contact should be the only lines showing the orange lightning bolts.


switch 4 will be a on if my ST system is in alarm… also how do i turn off event subsciption


tried red and green snapshot and both had all my codes, so i duplicated master sms piston… xxxd the values and changed the name so i could save it…then i took snapshot


red and green snapshot both have all my infor


turn off subscription by clicking on the trigger (sw1 switch is on), then the cog symbol in the pop-up, then you will see the subscription options. Change to ‘Never’.


btw… I find that after saving a piston, it is sometimes necessary to toggle switches on/off/on so webCoRE can learn the current state.

Can you see the master piston being triggered by the trigger piston?


i’ll test again
motion sensor now showing in log when i activate it… my mistake…still no text thoughsub%20off


toggled switch…no longer shows in log…still no alarm


Are those logs set to ‘full’?


minimal…here is the most of the full log showing motion active


So that all looks good.

If you look at the logs of the master piston, does anything happen at the same time?

Send it to me on PM if it shows anything confidential in the logs


master%20log%20only%20error this is the only thing that shows may be error the rest look good…i can try to pm you…


Thanks Robin for all the help…everything is working fine now