Replacing wu weather commands with twc commands, getting "can't find variable" errors


Finally getting around to replacing wu commands with twc commands. When wu pulled its api, I fiddled with updating. For whatever reason, couldn’t get it to work. I figured I’d wait a bit and see what others ran into. “A bit” has finally arrived.

I read a bunch of posts, the wiki, more posts, and replaced $weather.conditions.current_observations.temp_f
with $twcweather.conditions.temperature
in one tile to test. I expected to get current temperature back.

What I get back is
Variable $twcweather.conditions.temperature not found.
This is a straight replacement of one string for another. Obviously I’m missing a step, and have been unable to find the answer in forums or wiki.

This is just eding the piston.

I ran the piston to get the full text of the error because I am doing this on my phone and the screen isn’t wide enough.


CrazyOtter is going crazier. Help will be much appreciated.


Usually, in an expression box, that code should be outside of quotes, and not using curly brackets.



Nope. Braces gone, same message.


Then my next guess is your webCoRE may need to be updated.
Do you remember the last time you did that?

Side note:
Do any of $twcweather commands work for you now?


Updated as in “update thru SmarThings IDE”? I checked just before I started tinkering. I seem to be all up to date.


And, no, none of them have ever worked.


I am sorry, my freetime is very scarce the next couple of days, but all clues are pointing towards you needing a webCoRE update. New code was introduced a few months back to account for the new $twcweather


You need version:

02/23/2019 >>> v0.3.10a.20190223 - BETA M3 - Added $twcweather to replace discontinued $weather, added new :twc-[iconCode]: weather icon set, fixed content type for local HTTP requests

or newer…


Is there a way to force an update even when the system says everything is utd?


Yes, but I have to go right now. Hopefully someone can walk you thru the steps.

The wiki has it, but I don’t have the link handy

I will check back here in 15 hours or so…


I’ll check the wiki. Thanks!


Anybody else with suggestions? Else I will await WCmore’s return. I’m not in a rush (obviously).

WCmore is correct. My webCoRE is not up to date. The IDE says I’m current, and I can’t seem to force another update.

The code at the top of all my pistons says I’m current.

However, the engine block says I’m not.

Baffled by …um…computers


Thanks for your patience, @CrazyOtter

I have scoured the Wiki, but unfortunately, I cannot find any reference in how to force an update to webCoRE.


Cra…crud. I guess I resort to the old stand-by: delete and reinstall. @WCmore, thank you for your help. At least you reassured me that I wasn’t missing something obvious.


It might be wise to backup your pistons locally before attempting that.


Yup. Did that last night, just in case. Thanks. (Just because I’m paranoid doesn’t mean they’re not out to get me.)