Rooms Manager: Smarter Rooms: Personalized home automation with Occupancy

rooms
manager
automation
occupancy
rules

#583

Yes on most current update. Ok. Just tried this/. Created a simulated switch in ide. Called it kitchen lock. If I say turn kitchen lock on it will turn that switch on. Then in room manager set up I edited the preferences for locked to react to the simulated switch. When it turns on the state in the kitchen room changes to locked, when I turn off it changed to checking, then vacant.

If that helps at all


#584

With the above workaround. If you open the rooms manager to locks, instead of only switches, I could make a virtual lock ad]s the trigger. Then say ok google lock stuff and it would turn a virtual lock called stuff to lock or unlock the room…

Just a thought


#585

thanks. that is working as expected and does not need the lock only capability.


#586

So I need to create the virtual switch for this to work? Correct and then say turn on or off ?


#587

its not an workaround though. :slight_smile: if in locked settings a locked switch is specified the room will change to locked state when that switch is turned on.

in that latest version it does support the lock capability. if you check any of the room device with webcore it should show the device lock command.


#588

unfortunately since home or alexa neither support the lock command directly either have to create a routine to trigger the lock command or add a locked virtual switch in the locked settings and turn on that virtual switch to set room to locked.


#589

Got it, thank you. Now to figure out a naming convention to distinguish between the kitchen room and the kitchen virtual switch, so that it is intuitive to say to google… first world problems ]. I tell ya


#590

Ahhh, figured it out. In google home you can do shortcuts.

When I say lock kitchen,
Then do
Turn on kitchen lock switch.

Sweeeeet!!!


#591

Please correct me if I am wrong. The locked states keeps the occupied state from turning off, thus cancelling rules also?


#592

the locked state assumes manual control of all devices so no rules are evaluated.


#593

Are the custom device handlers not accessible right now for you, I keep getting a internal server error. It just seems that way with my ones that are using a github repository?


#594

yeah i cant get to update repo either.

ST is really kicking off the new year well! :roll_eyes:


#595

Is anyone else having issues with the rooms not working after updating from repo? I know there was some problems with ST and the GitHub repo. I was able to update my apps tonight, but now nothing is functioning.


#596

looks like the GitHub issue was resolved at 10pm EST. have you tried running another update from repo for the DTH and both smartapps then checking if all works normally?


#597

There is no option to update the app or the DTH from the repo.


#598

for the DTH and both smartapps from the IDE go in to EDIT and then publish them. if that does not help we can try forcing an update from the repo.


#599

Going into Edit and publishing had no effect unfortunately. How would I force the update?


#600

sorry didnt get a notification that there was a response.

easiest way to force it is edit the DTH and both smartapps in the IDE and comment out a line. then update from repo for DTH and smartapps … it should show you there is a conflict … from there save and publish all.


#601

made some good progress on the device tiles updates. there are still a few cleanups. more verbose hopefully easier to read for all but specially for new users. hoping to get this out tomorrow.


#602

UPDATE: updated version 0.14.0 to github with the following changes:

*  Version: 0.14.0
*
*   DONE:   2/25/2018
*   1) update device tiles to be more verbose.