Shades no longer able to DO 'Move to preset position;'


I have had a piston running forever now that sets shades to the ‘preset position’ at a certain time past sunset. There doesn’t seem to be an option anymore for ‘set to preset’. I do have that option for the device in the ST application and they do move to preset. Seems like something is wrong with Webcore?

As you can see the option used to be there: but no longer

Thanks for any advice!


My educated guess is that your “Dining Room Shades” are using a different Device Handler than the other two Shades.

You can check this theory by logging into your IDE, and then clicking on “My Devices”.
Take a look the “Type” next to all three of those devices.


Hmm checked that, they are all using the same DH. Just seems webcore is somehow confused as to the functionality of the shades… seems to be showing me options for lighting? It also does work on all the shades from the ST app - so makes me think its a WebCore issue …


Try deleting the offending device from devices in the webCoRE SmartApp, save, then add back in the SmartApp.


Better yet, remove the device. open the device handler in IDE and save/publish it again. Then add the device back. There is a known cache issue with existing device handlers/smart apps in IDE and saving/publishing fixes it.


Appreciate the replies.

Tried the troubleshooting, still getting the same issue.

These are the options for the shades: (no preset option)


How about using a variable to create your own personalised preset option?


Just curious - in your examples above, they show room shades. Are those groups or individual shades?


Combination one is 2 shades
1 is a single shade


I could I guess, the ‘do move to preset option’ did used to be in this list though. No config changes or DH changes.


i found the same issue. did you ever figure it out?


No I’m convinced it’s something in webCoRE that changed.



thanks for that, saves me going crazy trying to resolve it.


Has anyone found a solution to this?


Nope still missing/broken


Is there any way to get someone to actually look at this? As summer approaches this is super annoying…

Or any way to flip this to a bug?


How about STOP
even STOP is gone…
At least in that case I could turn them on WAIT 2 seconds and STOP…
It might not be the desired preset but gives something close…

Anyone knows about the STOP command???

**UPDATE : **
Found a horrible workaround but this is what I got so far…
Webcore still closes the blinds but I wanted them to go up in the morning up to 50% (Used to be PRESET)
Now the new way opening them up to 50% level is SMART LIGHTING app in ST APP.
Created a routine that opens them up tp 50% every morning at 7.30 (you can use simulated switches, motion detectors, open-close sensors etc)
I would hate splitting my house system in between ST APP automations and Webcore, but it’s gotta do it for now.


You could set up a virtual switch based on this that would trigger to move the blinds to 50%, that switch could then be used in webcore.


I have a Somfy blinds with a Zrtsi Z wave bridge, and this is working fine for me. I just set them to level 50%, and they go to the preset position, wherever that may be. See line 71 in my piston. Webcore treats my shades as dimmers.