Simulated switches and alexa problem - just happened


First of all I am so sorry to ask this question here. I hope someone can give me some answers because I just got on the phone with amazon ALEXA tech. help and this is the response I got:
"Sorry sir, I’ve never heard of SIMULATED SWITCHES or VIRTUAL SWITCHES before. Do you mean you don’t actually have the switches in your house with you???"
Boy oh boy…

The old switches I had, sometimes working sometimes not and the alexa APP says they are not responsive.

I did all the trouble shootings I know:
- Disable and enable Smartthings skill in alexa app.
- Delete and recreate Sim Switches in SmartThinds IDE.
- Tried an app written by M. Struck that creates virtual switches for alexa. It did create the switch and in Smartthings app it works. And it shows it is connected to alexa but in alexa app it’s no where to be found.

So, no luck.

I just wanted to ask,
Anybody else is having problems discovering simulated switches or using them in alexa???
Are they declearing a war to WebCore???
Ps : I am already trying all the websites I know, I hope someone can point me to a direction for the answers.

Thank you so much


Log out of the Alexa app and back in, have you tried that?

If I’m understanding this correctly, webcore is not seeing the virtual switches that you created?


Yes I have tried that.

No no I have no problem with webcore. The only reason I am asking the question here is, most webcore users depend on simulated switches.
1 - Alexa is not seeing the new simulated switches.
2 - All of the old switches i created look OFFLINE now in alexa app.
But they all work really well if controlled via ST app or ActionTiles.
Voice controls are GONE… no longer working.


Check the device type you used because there used to be only one type of virtual switch, now there’s another version in the drop down list. Might want to check that also if it has any impact on what you’re trying to do.


I’ll check that right now.
Thank you so much.


Tried bunch of different switches (Virtual etc) bu no luck.
Other than that my current switches (in alexa app & routines) stopped working with voice command.
Alexa pretends it’s happening but nothing inside the house happens.


Anytime I add a new device (or even change the name of the device) I have to say:
“Alexa, discover devices”.
It takes her about 20 seconds to run, but she activily searches out devices to (re)connect to, After the discovery, you may have to wait a few until the app updates, but vocal commands should work immediately.
(Also, once she reconnects, you may have to regroup devices in Alexa, since she thinks this is a ‘new’ device)

I have had 100% success with “Simulated Switches” created from the IDE, both in webCoRE & Alexa.


Your mileage may vary, but I have often incountered problems when using “Virtual Switches”.


Normally that exactly how it works.
But about a week ago I was no longer able to add any new sim switches.

  • I see them in ST IDE.
  • I see them in WebCore.
  • I see them in ActionTiles.
    And they work.
    I cannot add them to alexa.
    And all of the switches I have (That you and I created earlier) show “The device is unresponsive”
    the picture is just an example of over 200 devices.

    I thought maybe too many switches and started deleting some (the ones that no loner in use).
    But no luck.

Could you do me a favor and add a new Sim switch to your system IDE and test it to see if alexa can find it! ???
i’ve been researching the internet and the only case I saw is back in 2017.
Apperantly no one is experiencing this currently.


I was able to replicate the issue. After a bit of reading and testing, I found a easy solution.

  • Go to
  • Click ‘Skills’ in the left margin
  • Click ‘Your Skills’ top right
  • Scroll thru the list and click on this:
  • Choose ‘Disable Skill’ in the top right
  • Wait at least 30 seconds
  • Click on ‘Enable Skill’
  • In a new window, authorize (pointing to your correct hub)
  • Back in the first tab, click on ‘Discover Devices’

All my old devices & the new test SimSwitch are available for voice commands, and visible in the Alexa app!


I got really excited when I see that you replicated the same problem… but the solution did not work.
I waited about 30 minutes before enabling the skill.

None of the new ones were discovered
and all of the switches (except couple wifi switches) looking OFFLINE… it says everything is OFF line… (Some are actual GE wall switches, some are simulated switches)
but they do work if I control them via ST app or AT or WebCore…

I have about 267 items in alexa (Everything) could there be any limit to devices???
I had a similar problem with Action Tiles and I was warned by Terry that the limit was 100 devices (Tiles)


I tried the same thign again and ST gave an error…
Selected (Alexa authorization) can not be completed. Please email bla bla…

tried one more time and it worked…

Maybe instead trying to figure out what might be wrong with Alexa, I should open a ticket with ST


I don’t know if it makes a difference, but I used a full desktop PC browser to go to

My research indicates that that may be best. ST made a change, and it has impacted some people.

Slightly off topic, but didn’t you tell me at one point that you had two Alexa accounts for your household? Or was it two ST hubs? (either way, I wonder if the wrong account is trying to connect)


Thanks for the help Wcmore…
No what I have is 2 Ph Hue hubs.

I have opened the ticket with ST…
I should just wait…

Some switcxhes still work with alexa voice command but some won’t…
Probably it will be fixed soon.


Tried something else.

  • In Alexa app I clicked FORGET ALL MY DEVICES (267 of them)
  • Discover my devices.
  • Discovered 68 devices.
    Not even a single one from Smart Things App/Hub (Switches, plugs, outlets nothing)
    Not even my sonos speakers.

The only discovery is from PH HUE hub. Light bulbs and some wi-fi or alexa certified plugs that are not zwave plugs.

So I would say at this point my alexa is not seeing my ST hub.
My house is like, as if I don’t use a ST HUB.

any thoughts?


Tech support is never as fast as we’d like them to be, LOL But I must say, good observations!

My first hunch would be to go into ST and disconnect from Alexa… Reboot / wait etc… then connect a “new” device in ST, and point it to the Alexa account, hopefully reauthorizing again in the process.
(I haven’t tested this, but I believe this would force a reconnect)


Yeah tried bunch of those…
so weird.

But I have not tried adding an actual device - like a smart outlet, wall dimmer etc - I’ve been testing with virtual stuff.

Tomorrow I’ll try some outlets and see where that goes.
I wish I knew if this was Amazon or Samsung problem?


This makes me think it is not related to SimSwitches, but your idea for testing cannot hurt.

I think it is the opposite of this… What I mean is, I think that ST that cannot see Alexa.
(which is why I recommended disconnecting from inside the ST app)

Although, now that I think of it, maybe disconnecting Alexa while inside the ST app (or IDE), followed by disabling the ST skill inside Alexa may do the trick. (this way the bad connection is broken from both directions) I would disconnect from the ST end first though, since the hub is the ‘master’

Did it prompt for an authorization in the process?


Well look at that…

I totally forgot that we can factory reset amazon echo… I was thinking about resetting the ST HUB and instead i reset the echo and that SOLVED the problem…
All of my ST devices are back and working…

Thank you all for your help.


Thanks for the update. Glad you got it working!!