Smartthings & Hubitat in one dashboard?


Hi folks,

I’m in the process of switching from ST to Hubitat. I’m taking it slowly and so I have two Webcore instances. One for Smartthings and one for Hubitat.

Is there a way of having both my Smartthings Hub and Hubitat hub in one webcore dashboard? Up at the top I mean where the icon for the hub is.

If not, what is the best way to switch between dashboards. Currently, when I open Webcore on my PC it is the hubitat and when I open the smart app on my phone and tablet it is the Smartthings. Basically because I can’t figure out how to switch!

Thanks in advance.



You can not have both on one screen.

Register Instances for both from the side menu, then switch between the two in the upper left of the screen. There is a pull-down where you can switch between all your registered instances.


or some folks open multiple tabs in their browser and open ST webcore in one and Hubitat webcore in the other.



Ah, I see.

But now I can’t swap back! I keep getting an error. The, There was a problem loading the dashboard!!! On both!

Is webcore down?


that is normal when switching between the two. the message goes away after 15 seconds or so


It looks like today’s 0.3.111 release fixes this misleading error message :tada: I’ll update the notes.


But it won’t load the hubitat one at all now though!


Edit, cancel the last - I’d updated but didn’t think I had.

OK, it’s after the update that the dashboard stopped loading. Prior to be doing the update I followed the above and saw two webcore instances as I wanted.

I swapped to the ST one and then I got the error - There was a problem loading dashboard.

I now only have the ST instance registered and each time I try to register the hubitat instance it opens webcore but with no pistons and in the balck bar it just says “Loading”. Then that fails and if I hit f5 it opens again but with ST and still no hubitiat.


logout and start over by registering both instances


It’s not worked. Now I can’t access any of my devices on my PC’s smartthings webcore instance, but it does on my tablet!

When I look at pistons on the PC there are no devices. The do however show on the tablet.

I think the issue lies in the fact that I had problems a while ago. I originally set up ST with one email address, then somehow I also have another account, my Samsung account, with my main email address.

Both have smart apps and both have Webcore! But up until I updated to todays update, it worked flawlessly.


hard reload of the page?


If you are running most recent HE, update again, as during these updates on the dashboard, I had to make some changes on HE.

If you used HPM to install webcore on HE, have it do a repair on webcore (that forces it to reload the latest code).