ST Migration / webCoRE Issue


#1

Apologies if this isn’t the correct category, I’m just not sure where to post this question…

Long story short, I’ve had issues with the new ST migration. Finally got resolution by ST engineers setting up a new ST account and migrating everything to it. My hub name and location remain the same, but my ST account has a new email address. When I go to webCoRE I receive an error “There was a problem loading the dashboard”. The page is blank (non of my pistons are showing) and the top left has the following “\ loading…” in a black bar.

I’m not sure how to redirect to my new account, can anyone help me? It seems like it should be simple, but I’m missing it…

Thanks in advance, Bill


#2

Tagging @ipaterson

Just checking, you have tried logging out of the dashboard, cleared browser cache… gone into the ST app and your instance of webCoRE under settings and clean up and rebuild data cache, then generate a new register code, open the dashboard, enter that code, enter your security password :slight_smile:

Doubt that will resolve it but fun to make you go through 10 steps ha ha


#3

Same thing is happening to me. Clearing cookies and cache in the browser and rebuilding data cache in the app does not fix it. Running Firefox 80.0 The Dashboard does work fine in a Firefox 80.0 Incognito tab. It also loads fine in MS Edge browser. ¯_(ツ)_/¯


#4

well… I’m still not having any success, but, with the new app and automation it looks like I can perform all of the same things without webCoRE with the exception of my vacation lighting routine.


#5

Have you logged out of the webCoRE dashboard or tried a different computer or web browser?


#6

yes. I’m on my work compute with IE instead of Chrome and getting the same thing…

The first time I tried I actually saw my pistons, but, when I clicked on one it went back to “loading”


#7

It sounds like the token that webCoRE uses to communicate with the SmartThings platform is no longer valid since they changed your account. Registering a browser works, but the details provided to the browser do not allow it to communicate back with SmartThings to load your pistons.

Please install the latest development version of the webCoRE smart app by pasting this code into the editor for the webCoRE smart app at account.smartthings.com > My SmartApps then saving and publishing. This will add a new option in the ST app. Please use webCoRE > Settings > Security > Reset access token then attempt to sign in to your browser again. You can paste and publish the original webCoRE smart app code to go back to normal if this works.

For anyone else using the above advice, please heed the warnings in the smart app before resetting your access token. This is safe to do unless you use External URLs for your pistons (e.g. to trigger a piston from a third party platform with a web request) – any External URLs that you are using must be updated since they contain the old token.


#8

Edited code and reset token. I logged back in and it appears to have solved my issue! Thank you!


#9

Glad to hear it! Several people had this issue earlier in the year - it would be nice to publish that new option but the pandemic has pretty much stalled anything other than emergency webCoRE updates. There are a number of other changes in the development release, so it is best to revert the webCoRE code back.