Thermostat Status Device Tiles



Sorry for the quick reply, but was your intention to only display the setpoints? If so, I think I have it fixed. By not putting single quotes around that highlighted section, you are performing a calculation. By putting quotes around it, you are only displaying the value.

i.e. in my case ‘68 / 72’ rather than performing a calculation function.

By changing this, my temps are displaying properly.


Fixed piston:


Oh I see what you mean now, thanks for the post with the correction. I’ll correct it and repost the updated version on the top post once I’m done with another change I’m working on now.


I updated my first post with a new version of this piston with the following changes.

  • Fixed issue with Auto Mode not displaying correctly, thanks kxavier_23 for the fix.
  • Added CelsiusMode Variable as an option if your Thermostat is set to Celsius already so it’ll display correctly in the tiles. @kevince52: this should help with the problem you posted above. Please let me know if this works if you have a chance to test it out.


All of the Device Tiles are now located on the webCoRE Wiki site located here including the Thermostat Status Device Tiles:

This was done to make it easier for everyone to view all of the device tiles instead of going through 6 different posts and makes it easier for me to edit them.


Good Thinking, Thanks


I’ve imported these but I’m having some issues it keeps counting up to 13 when i only have 12 thermostats in my piston? then i get another tile for the first zone and a “device not found error” and it never goes any further because it never resets the {tile} integer to zero

any help?


Can’t get this to display modes properly for a Honeywell RTH9580WF. It’s always in Idle mode with the snowflake spinning no matter what mode it’s actually in. Temp settings work but that seems to be it. When I took this screenshot it was currently in heat mode.