Unable to modify devices in the IDE after installing Webcore


1) Give a description of the problem
I’ve been migrating my devices and automations from a V1 hub to the V3. Currently I have 2 locations under the same account. I’ve also started using Webcore. After migrating several devices (excluding from hub V1 and pairing to hub V3) I’m suddenly getting this error on the IDE when trying to modify devices: Device update error: Update not allowed, only location owners can modify devices.

I’ve tried Chome, Safari and Firefox and incognito and I still get the same error.

The response from Smartthings is:
With the screenshot of the device you have sent in I see you are using webcore, we unfortunately do not support webcore or any third party device handlers/ smartapps. The next troubleshooting steps we would like to try would be to remove webcore and then attempt to edit your device. If you are still experiencing the same issue after please reach back out to me here.

Before I remove webcore, I’m wondering if anyone else has come across this issue or might have additional suggestions on how to solve.

Thanks in advance!


Not having the issue you describe but before you uninstall webcore, have you allowed webcore access to these devices yet? You could try removing the device from webcore and then seeing if that makes a difference but I doubt it. Samsung is difficult about support if you mention you have any third party apps or devices they officially don’t support.

I recently went around and around with them for two months only to finally discover my second hub/mesh router was causing all the trouble. Once I removed that, the problems went away. I had to discover this on my own after they made similar suggestions like removing webcore, removing and Rea-adding devices, etc.


Yeah I figure it’s a long shot as there are so many different variables at this point. If I were to remove webcore, would it be possible to save my pistons somehow for future reference?