Virtual Switch or Simulated Switch SmartThings


I have recently had an issue creating a virtual switch in SmartThings. After I enter all the information to create the device in the SmartThings IDE, I get a message that I do not have authorization to create the device. I’v tried multiple times. I also have about 6 Virtual Switches that I created months ago that are working just fine. I contacted ST level 2 support about this. The answer I got was that because I’m using WebCore and WebCore device handlers, I can no longer create virtual switches. They said because I use WebCore, they do not support virtual switches. This just seems crazy to me. Anyone have any similar results or success? I personally think this is a SmartThings issue.


I think this is the same issue some folks have been experiencing for a while now. Try creating the device while logged in the IDE using incognito browser.


Thank you! It worked perfectly. I find it absurd that a level 2 tech at SmartThings would provide that kind of information. This pretty much proves it has nothing to do with device handlers. They used to have good support - not so much anymore… Ugh.


LOL, I know, you should email them the ‘fix’ :smiley:


I’m probably not the only one, but I don’t use virtual switches anymore because of issues like this. Simulated switches only.


I couldn’t create either one. The incognito browser allowed me to create both.