WC Update 1.0.88


Has anyone updated to this version via HPM? Theres a post on the WC github page where someone has had problems.
I’m also wondering why you should reboot HE prior to the upgrade?


I’ve been having the discussed problem while using HPM to update webCoRE for a few months. I now install updates manually.


I’ve just tried and it’s failed. I’ve never had any update failures via HPM before.

I’ll either go for the manual update or wait for a solution.

Given the manual method works, I wonder if a change to HPM is needed to allow an update to run for more than 5 mins?


There is a thread on this in the Hubitat community

Short answer is with latest firmware, need to do the manual imports for apps and drivers

The issue is a longer timeout is needed, this was attempted with HPM, but Hubitat will not allow the longer timeout to be used. HE developers are aware.



Do you know if this will be fixed by the HE developers, and any time frame?
I dont think I need the update, so could wait. Is it just this particular update that has the issue, or are future updated likely to be the same?


They are looking at it. I don’t know if this is an easy or hard fix for them…


I’ve just noticed an update to HPM, with the timeout increased to 7 mins.
I’ve installed the HPM update, rebooted and tried the WC upgrade again, but it still fails in the same way after around 7 mins.


I’ve just updated my HE 7 hub to WC will still not upgrade through HPM