WebCore and EventGhost


#61

Well, I can send commands from WC to EV, but can’t send anything from EV to WC. I guess I’ll have to live with that. I appreciate your help…just wasn’t meant to be, I guess.


#62

Even though I would never use EventGhost to try to ‘control’ an unwilling user,
here is an example of a command going from EventGhost to webCoRE.

It actually works brilliantly on a machine where it is desired, but it is too easy to bypass/change if it is not.


#63

Believe me…I’ve tried your code. Nothing’s coming back from EV. I set up this piston so it would send a notification and flip another switch. Neither works. I’ve even been trying the TEST button, and nothing’s happening in WC. (I’m playing the sounds to make sure EV registers the ST switch)

Doesn't%20work


#64

Your link in EventGhost is not what I gave as an example:

The URL is the URL of your piston with NO triggers. The endings arguments can be whatever you want, but must match the code in that piston.


If you are a visual learner, here is the beginning of that code as seen in EventGhost:

temp


#65

Crap…I was missing this part…it works now. :blush:

I’ve noticed that my WC URL has changed. Does it change every time I make changes to the Piston? Does that mean I have to update all the URLs in EV when I change the Piston?


#67

I have never seen a piston’s URL change unless I duplicate a piston.
The new piston will be a new unique URL, but the original stays the same as far as I know. I have many pistons I made AGES ago, and edited dozens of times since then, and it is still using the same URL


#68

Things are working better now, but I have a weird question.

I was setting up notifications to determine with account is being logged into. When I switch accounts using System.ConsoleDisconnect, I get two notifications (I guess it connects/disconnects twice?) When I tried adding the “payload”, the notification doesn’t work. Is there a better way to determine this? I found some discussions on the Eventghost forum, but nothing seemed to address this, and there was a huge Github install that I was leery to mess with. https://github.com/EventGhost/EventGhost/blob/master/plugins/System/SessionChangeNotifier.py

User%20Account


#69

Some triggers can be a pain to identify in EventGhost. (when there’s so many to choose from)

I often make a test trigger doing something simple like play a sound effect. This lets me quickly test many variations of the trigger until I find the best one. Sometimes, I may even test 4 or 5 different triggers before I am happy with the results. This is normal considering you are seeing what is happening at a low level on your machine. For example, my biggest challenge so far has been catching the right event during shutdown.

temp

(There’s no way I could have guessed that on my first attempt)


#70

EventGhost is nice, but does not work at system level; it is a user-level script.

A better solution is to use Windows’ built-in Task Scheduler. Win10 does curl commands. You can put them in a batch file, or do a bat-to-exe thing if you need to lock it in and make it un-modifiable.

So you can set up Task Scheduler to run on system events, just like Eventghost. And it will do so regardless of who is logged on.


#71

Great idea Glen for outgoing commands (PC to webCoRE)
That only goes in one direction though, right? (not from webCoRE to PC)


#72

I don’t know. Though hypothetically, it should not be impossible. After all, this is a typical vector for malware- so we should be able to leverage it too.


#73

You’re gonna hate me, but I wanted to add some more mp3s, and I can’t remember the procedure. It looks like his EG lost the original commands. Not sure what happened. I swore I wrote down the steps but can’t find them.

I’ve created a (blank) piston and copied the external URL, but don’t remember how to get the ST virtual switch to show up in EG so I can drag/drop it over…


#74

Open the SmartThings app on your phone, and then:
Automation > SmartApps > Send Event to EventGhost > Switches
Check the Simulated Switch you want EventGhost to see and react to, and then
Done > Save.


Pro Tip:
Depending on the circumstances, sometimes I do not add a device, and just send a http GET request directly to my PC to trigger an event.


#75

Ok…I’ve had it set up that way, but it’s not registering. I guess I messed something else up.

[EDIT]

Figured it out. My computer IP address is different. All fixed now.


#76

OK, this is weird. I got my daughter a laptop and tried installing EG again. I can test the Import URL line and it sends a notification to ST per my piston and turns the simulated switch off and on. However, when I select the switch in ST, it doesn’t register in EG. How do I keep getting this wrong?


#77

Right out of the box, EventGhost can trigger any piston using the URL…

To go the other direction, and get your computer to respond to SmartThings, there are two main ways. The easiest is to use the EG plugin called “Webserver” and make sure it is in your “Autostart” folder…
temp

I like using “ST” as my Event prefix to make it stand out a bit…
temp

Afterwards, you can:
temp
(using a static IP for the laptop is recommended)

Which returns this when the piston fires:
temp


The other method takes more preparation. You need the ST plugin called “Send Event to EventGhost”, and must register each device as mentioned earlier.


#78

OK…webserver worked. Last part to fix.

I’m having trouble finding these. Do I need to shut it down and log these to a file? I see them in my computer’s EV, but don’t remember where they came from.


#79

The shutdown one is difficult to capture, but you can manually drag any lightning bolt, and then edit it accordingly once it is on the right side.